Path Issues

On Linux 3.8

I compile Panda, but when I go to samples and execute one of the programs I get…
ImportError: No module named direct.directbase.DirectStart

So, I export PATH, PYTHONPATH, LD_LIBRARY_PATH to be pointing to…

run samples/Astroid…/python Tut… (and get…)
File “/home//Downloads/panda3d-1.8.1/built/direct/showbase/”, line 14, in
builtin.config = getConfigShowbase()
NameError: name ‘getConfigShowbase’ is not defined


Does anyone know the rules for path/package configuration of Panda3d 1.8 on a build that is not installed ?


Is there a reason you’re not simply installing it onto your system by installing the .deb?

Also, if you’re getting that error, you likely have a build that was partially built without Python/Direct support. For instance, if you changed the build settings mid-way (ie remove --everything) or so. You might want to make a clean build and make sure it has Python and Direct support.

Yes there is, it’s because they dont work well. It actualy detected my OS but still would not install correctly.

Both Python and Direct support are being built.

The only thing I’ve been able to get it to work on is Ubuntu 12.04 LTS (On my tiny laptop that I use when riding the train)

I need to get it to work on a VM, I try the ones that are good for me. I’ve tried CentOS 6.5 final
I looked at the above posting went and downloaded debian weezy 7.0 along with the install file provided for it.
Only to have it complain, that it needed about 500 different libraries, and after fixin that, Oh it needs a display now.

I’ve tried LuninuxOS, I have a native install of it on my desktop. it’s 3.8-generic. The deb files will not install correctly.

I’ve tried building the deb from source with all the required packages. but again, it will never install correctly.

I’ve read the instructions, I’ve checked panda3d.pth, Config files, I’ve put things in etc, lib, usr/share/panda3d etc…

making sure that MY python version is what is being used when building, so it matches.

What OS will work with the 1.8.1 deb files ? that will also work in a VM ?



I installed …
“Linux ubuntu 3.8.0-29-generic #42~precise1-Ubuntu SMP Wed Aug 14 16:19:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux”

Ubuntu precise1, in a VM, and I git it working with the DEB file, after do a ton of apt-gets !

Thanks for the support !