Pandaa and physiscs engine (Panda vs ODE)

I’ve been looking around and asking questions for an upcoming 3D game dev project I’ll producing, that will start mid-september.

1- I like Python (and comfortable in it)
2- I have 14 3d modelers-students that will be doing this project as their last session before being fed to the sharks (trying to get jobs in the game industry :wink: )
3- Blender was an alternative BUT we can’t get 3DS Max animation rigs into it
4- Ogre, IrrLicht python bindings don’t look appealling compared to what I looked at concerning Panda

Problem: physics
Most of what I have read about Panda tells me to use ODE (pyODE or integrated ODE ???) instead of the built-in physics engine…

Problem : Learning versus Time
I’ve read a little bit of these forums (fora ?) about ODE but can’t understand the code I’ve seen: I thought that using PyODE would be a question of connecting objects (Panda) to physics event handlers(PyODE) but can’t find anything to direct me (an example ???)

I don’t have a great deal of time to experiment:
A- should I stick with Panda’s physics (Ã la Roaming Ralph)
B- If using ODE is a good idea, where can I get a quick-start on it? (in it’s connection to Panda, not only it’s maths)

All comments welcome (I’m just an egg, - in the grokking sense, not Panda’s :wink: )

PS I would preferably use Panda, as a programmer myself, but this is not for me, it’s for my students
Blender really is OK, even if it’s game engine is not presented as being as sturdy as Panda - So really, any comment , suggestions, will be gladly received…

Check out the code snippet, there are some samples, enough to get you started.

I try a lot of time to enable the 3d aceleration, but always refuse to it.

How put panda in software mode?

Most stuff like that is stored in pandadir\etc\Config.prc.
If you are running windows, most likely it will work in either directx 8 or 9 – change the line that says “load-display pandagl” in your Config.prc to something like “load-display pandadx8” or “load-display pandadx9”.

If that still doesn’t work, and updating your video drivers doesn’t help, you can change it to software mode. Do that by changing these lines:

framebuffer-hardware #t
framebuffer-software #f

Change them to this:

framebuffer-hardware #f
framebuffer-software #t