Panda3D-1.7.0.dmg and OSX 10.4

Is Panda3D-1.7.0.dmg expected to work on OSX 10.4.11? I think I should find out before I spend much more time debugging it :slight_smile: … ted_on_OSX suggests I should be able to run ppython after installing 1.7.0, but I can’t:

$ cd /Developer/Examples/Panda3D/Asteroids/
$ ppython
-bash: ppython: command not found

Turns out ppython is a broken symlink:

$ ls -l /usr/bin/ppython
lrwxr-xr-x   1 root  wheel  99 Nov  7 09:17 /usr/bin/ppython -> /System/Library/Frameworks/Python.framework/Versions/[b]2.5[/b]/Resources/
$ ls /System/Library/Frameworks/Python.framework/Versions/
[b]2.3[/b]/     Current

I tried running python2.5 directly:

$ python2.5 ./ 
Traceback (most recent call last):
  File "./", line 13, in <module>
    import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

Ok, /Developer/Panda3D/lib was not added to my PYTHONPATH

$ PYTHONPATH=/Developer/Panda3D/lib  python2.3 ./ 
DirectStart: Starting the game.
Traceback (most recent call last):
  File "./", line 13, in ?
    import direct.directbase.DirectStart
  File "/Developer/Panda3D/lib/direct/directbase/", line 3, in ?
    from direct.showbase import ShowBase
  File "/Developer/Panda3D/lib/direct/showbase/", line 10, in ?
    from pandac.PandaModules import *
  File "/Developer/Panda3D/lib/pandac/", line 2, in ?
    from libpandaexpressModules import *
  File "/Developer/Panda3D/lib/pandac/", line 1, in ?
    from extension_native_helpers import *
  File "/Developer/Panda3D/lib/pandac/", line 81, in ?
  File "/Developer/Panda3D/lib/pandac/", line 79, in Dtool_PreloadDLL
    imp.load_dynamic(module, pathname)
ImportError: dlopen(/Developer/Panda3D/lib/libpandaexpress.dylib, 2): Symbol not found: _tempnam$UNIX2003
  Referenced from: /Developer/Panda3D/lib/libp3dtool.1.7.0.dylib
  Expected in: /usr/lib/libSystem.B.dylib

I tried python2.3 (thinking maybe it was because I wasn’t using the default system python). Same error.

Is 10.4 just too old?

The SDK build is not compiled with support for 10.4, sorry. You need at least 10.5 to use the SDK, or compile Panda3D yourself, from the source code.

The runtime does support 10.4, so applications you make using Panda3D will run on 10.4, but the requirement for the SDK is 10.5 for various reasons.

no worries, I figured 10.4 might be too old. I’m planning on upgrading soon so that will take care of that.