Panda3D 1.6.1 released

No, this release does not have built-in shadows in the shader generator yet.

This release fixes some bugs found in 1.6.0, and adds some minor features as well.

  • Threading layer is now enabled by default
  • cTrav.showCollisions fixed
  • Fixed broken MovieTexture
  • OpenAL is now stable on Linux, too
  • OpenAL now supports dynamic playrate changing
  • MayaPandaTool now handles NURBS correctly
  • Fixed particle panel and directtools bugs
  • Fix crash with collada exporter on Windows
  • ARToolkit jittering fixed
  • Now possible to override shader vertex/fragment profiles
  • Maya exporter fixed on OSX
  • Fixed depth texture crash for padded textures
  • Fixed bug that made OdeUtil.collide return empty geoms
  • Fixed crash with render.flattenStrong() when using trackball
  • Several improvements to the ODE layer
  • Performance improvements to GeoMipTerrain
  • GeoMipTerrain.setBorderStitching to fix seams between terrains
  • for installing Panda on Linux without deb/rpm
  • Several other minor bugfixes

Let’s hear those bugs. :slight_smile:

PS. Fireflies sample on Linux has been fixed, but I forgot to update the sample program itself. To get the fixed sample, grab it from here.

[size=0]imagine this:
UN!X user:
Are you gay?
Linux user:
I love you.
FreeDos user:
int 5>7?
Windows 7 user:
Fuck you retard![/size]

I still have my old xubuntu install CD, so I’ll have to install it now :smiley:

(pro-rsoft makes no comment about the subliminal message hidden in Dany0’s post. It’s not even funny.)
[size=0]…or maybe just a little bit.[/size]

i advice against using ancient linux-versions. unlike windows there are benefits from updating to up to date versions.

PS:(i agree with pro-rsoft)
[size=0] …will you stop your childish behavior??. this is not some teenage-spamming-forum,seriously. [/size]

(I agree with both pro-rsoft and ThomasEgi because it wasn’t meant to be funny, haha)

Congatulations pro-rsoft! your 2999 post! 1 to go!

So you mean you compiled maya2egg for 2008? You sly dog, I didn’t know you’d gotten back on that task.

I’ll give that a test in a minute, but first I already encountered one bug. First sample I tried to run crashed. Here’s the terminal session:

joseph-hockings-macbook-pro:~ jhocking$ python /Applications/Panda3D/1.6.1/samples/Music-Box/
DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
Bus error

And here’s the error window that popped up:
The application Python quit unexpectedly. The problem may have been caused by the libp3dtoolconfig.dylib plug-in.

ADDITION: and now the second sample I tried also crashed:

joseph-hockings-macbook-pro:~ jhocking$ python /Applications/Panda3D/1.6.1/samples/Infinite-Tunnel/
DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
Segmentation fault

Does the windows installer zip file require a Visual Studio installation? According to the download page:

“These archives contain everything you need to compile Panda3D from scratch, including the source code from SourceForge, the third-party tools, and the sample programs. The zip-file contains the third-party tools for Windows, the tar-file contains the third-party tools for Linux.”

I expected either a small gcc install to be included, or instructions saying I had to install something like MinGW. Instead I was greeted with an error saying Visual Studio could not be found.

Hi pro-rsoft,

Thank you for the release. But :

I know there’s no Windows build on the download page, and I don’t plan on doing anything about that. So don’t complain to me.

Is it a resource issue, or outstanding bugs, or other reasons a windows build is not made ? If it is a resource issue, can I offer some help to build it ? (although I have not built any previous panda version before)

I guess it’s due to treeform is so on the pyweek.
If you have all SDKs (Maya, Max, DX, etc.) and can provide a full build, it’d be really appreciated.

@ skeptic :
you can’t build it with gcc on Windows. Panda needs at least VSExpress.

hoo, nice, new version, for linux is needed to uninstall 1.6.0?

ynjh_jo hit the nail on the head.
How to compile it yourself.
Panda doesn’t compile with gcc because all proprietary sdks (DirectX, Maya, Max) are compiled against Visual Studio.

Two weeks ago, I promised Imagineering to release it within two weeks. So I did.

btw, you haven’t updated the home page - it still says 1.6.0. With regards to the Windows build I’ld be a bit worried that anyone new coming to this site right this instant will see no windows build on the download page, and go away, never to return. You should probably add the windows build section back in, with a comment to the effect of ‘coming soon, use 1.6.0 (See below) for now’.


Who is responsible for the windows build? Should I just try to compile it myself or should I wait for the windows version? I have had bad luck with compiling the entire panda thing, but could give it a try if there is going to be an extended period…

I guess I’ll wait on the windows version until someone someone puts one out. I’m more of a Linux user anyway, I just happened to be booted in windows playing a mmorpg that will not run under Linux/Wine. If only game companies would switch to Panda3d they could easily release games on windoze/osx/linux. Don’t they know what they are missing? :laughing:

wow! great new build! :slight_smile:
All my problems in Jaunty are now gone!
Thanks a lot pro-rsoft.

When I just tried this one again I got slightly different (and hopefully more informative for you) error feedback:

joseph-hockings-macbook-pro:~ jhocking$ python /Applications/Panda3D/1.6.1/samples/Infinite-Tunnel/
DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
Assertion failed: _core != (ConfigVariableCore *)NULL at line 264 of built/include/configVariable.I
Segmentation fault

Incidentally, note that this too gets the error window popping up about a faulty plugin, except this one complains about libpanda.dylib instead of libp3dtoolconfig.dylib

I also tried running maya2egg2008 and got an error after it had started initializing Maya, but I figure I’ll report more about that after the error in running Panda is fixed.

I got that same error when running makepanda, at the pzip step. Some pointer got corrupt somewhere, and I failed to debug it.
I just copied the .pz’ipped file from my linux box hoping this was a 1-time error, but apparently it isn’t.

Btw: I did get reports that maya2egg85 worked, but the crashes you’re having might be related to the configVariableCore crash.

ah so you experience the same error at some point too. Good, that’ll make it easier for you to debug (as opposed to an error that you need a mac to repro.)

If you need me to do any other testing to help track down this issue email me.

Well, that’s the problem - I can only reproduce the problem on Mac, not on Linux, that makes stuff considerably harder to debug.