Panda3D 1.5.1 released.

Hey guys, sorry this took so long. Here are the things included:

  • The x-file parser now is back to being case-insensitive, as it should be.
  • Panda plugins now use an explicit plugin-path.
  • Better DLL-hell protection under windows.
  • Added GeoMipTerrain (but no docs yet)
  • Using python -E in the start menu - really, this time.
  • Linmath classes now initialized when using python.
  • Implicit sort order for texture attribs.
  • OpenAL audio manager now gives control over streaming vs preloaded sounds.
  • Preliminary support for 64-bit linux (but thirdparty libs missing).
  • Fixes a dozen or so assorted bugs.

Here are some things I wanted to include but wasn’t able to, because the release was taking way too long:

  • Entire 64-bit linux thirdparty repository is pretty much empty
  • Documentation for GeoMipTerrain missing.
  • ODE support
  • OSX support in makepanda
  • Crimity’s fix to the MEL export script.

BTW, does anybody have any contacts at DevMaster? Their description of our engine is painfully out of date, and I can’t get anyone to pay attention to my emails.

Ah excellent:-)

For the 64 bit thirdparty stuff, I already have it online here - http://www.thaines.net/content/panda3d/thirdparty.tar.gz, and can fiddle it into any form you require. I shall try and put together a 64 bit Fiesty .deb file latter today and get it online. (Of course, next version of Ubuntu is about ready, but I usually wait a week or two to update, to miss the download rush. So I guess I’ll do another build then.)

So this repository contains ffmpeg and openal. Do those work?

No - I tried to get them to work, but gave up as I was pressed for time. But I did compile them, and those versions might work with further updates, hence why I left them in. I guess it might be better to distribute it without those however, so people don’t try and compile them. At least until someone (Me, if I can find the time.) gets them working!

Sweet at update! Will have to check it out later today.
Just to set the record straight, I didn’t really fix anything with the MEL export script… I should have… but just got it so it would work for me =P
So the credit really goes to ynjh_jo.
Thanks ynjh_jo!

panda3d.cvs.sourceforge.net/*che … daTool.mel

no changes to the CVS ?

Josh,

did cubemaps get fixed with the shader generator in v1.5.1?

I’ve tried to get them to work but again it’s painting one of the render to texture images to the model instead of the cubemap. Am I doing something wrong?

Ok, first things first - I’ve put up a 64 bit version of 1.5.1 - http://www.thaines.net/content/panda3d/panda3d_1.5.1-ubuntugutsy_x86_64.deb
I’ve tested a bunch of the examples and they all seem fine. If anyone want to mirror it feel free, though my webspace seems to be able to take the strain well enough.

For anyone who want to compile it I’ve stuck the thirdparty stuff up in the same style as the part 2 downloads from the download section - http://www.thaines.net/content/panda3d/panda3d-1.5.1-tools-linux64.zip It only contains the cg stuff, which is a bit weak - still no sound etc, but at least stuff looks good!

Compilation of this version works fine on 64 bit without modification, however creation of the .deb does not work because it writes an architecture string of ‘x86_64’ rather than the correct string of ‘amd64’. The solution to this is to replace line 3505 of makepanda/makepanda.py, which starts 'txt = ’ with the two lines

deb_arch = “i386” if ARCH!=“x86_64” else “amd64”
txt = INSTALLER_DEB_FILE[1:].replace(“VERSION”,str(VERSION)).replace(“PYTHONV”,PYTHONV).replace(“ARCH”,deb_arch)

Josh: If you can apply that to cvs it would be great.

mavasher: No, cube maps support not implemented yet.

ynjh_jo: no, MEL export script not updated yet.

lethe: ok, will do.

The .x converter still isn’t working. When I try to use it it gives me a list of error messages like this:

Error in dino.x at line 162859, column 3:
    }

    ^
Too many data elements in structure.

There are also other errors in there too, such as:

Error in dino.x at line 183, column 30:
  array FLOAT weights[nWeights];

Unknown identifier: nWeights

and

DWORD AnimTicksPerSecond;

Unknown template: DWORD

i had a problem installing panda due to version numbers, i could not figure it out till i saw this:

Josh,

I sent a PM to you with a contact for DevMaster.net. I hope it helps.

Steve

Wow, this is cool! Thanks!

About geoMipTerrain docs: I’m busy writing them. I might also write a sample, but I’m really busy at the moment. I’ll try to free some time for it. Same for ODE, I do have thirdparty libs but with modified headers, and not linked to Panda3D (yet).

“- Fixes a dozen or so assorted bugs.”

Kinda vague. Is there a list of what bugs where fixed?

Well, here’s the thing. The Disney guys do most of the bug-fixing. I do the releases. When I did the release, I saw a whole bunch of one-or-two line alterations. It’s obvious that these are bugfixes… but what the bug was, I have no idea. To find out, I would have to spend a lot of time reading the code and the CVS comments, and that’s time I just don’t have.

The deeper problem is that we have a lot of people who use Panda3D, but don’t contribute to the development.

I can understand your last sentence :slight_smile:

Now, for me , bluntly : I use Panda3D because I DO NOT WANT TO MESS EVER AGAIN WITH CPP… (coming from heart…)

Now the good news : i have somehow managed to stabilize my personnal /professional life (my son sleeps more than 2 hours per night, i’ve got orders to earn my living until end of 2009)
So i can spend a few hours per week to contribute on Python side of the world…

So if you see some manpower needed to write new samples, update documentation, make some .py utilities for model conversion …ask and i’ll try to stand up…

What panda really needs at this point are sample games. They need to be super-creative and fun. I’d like to keep it under 1000 lines of code. The graphics need to be absolutely top-notch, and the frame-rate needs to exceed 60fps.

As a teacher of game programming, I think the best way to write these games is to write them real fast (ie, in 3 days or less), and then if they turn out to be a lot of fun, then put on the polish:

gamasutra.com/features/20051 … r_01.shtml

Also, there are tons of maintenance-related tasks that need to be done. For example, the entire linux-libs-x64 directory needs to be populated. Just scan the forums, there are a zillion of these.

Sorting out DirectGui!