Panda not working out of the box MacOSX 10.5

Hi Just installed Panda and I am getting the following error.

I noticed also when I installed Panda it broke my PATHS. I could not do anything not even an ‘ls’. Thats fine I got that fixed up but Panda remains broken.

Also… I compiled python 2.6 to /usr/local/bin/python. This was in my path when I installed Panda. Dont know if that effects it.

I also tried running my Panda test python script with the mac os python.

Same result as above.

Thanks in advance for any help here.

You forgot to install the prerequisite Nvidia Cg Toolkit.

OK I must be missing something here because I have installed the toolkit form this page

I even attempted to reinstall panda but i am still getting the same error. I also tried to look for the sample applications in /Applications/Panda3d however this folder does not exist. Is this correct is there a major step in the install I have missed? I did not notice a page for mac installs in the doc.

Sorry, the manual page is outdated. The samples are in /Developer/Examples/Panda3D/.

thanks for that but I am still getting the same message…

the error suggests that cg is missing.

does the file /Library/Frameworks/Cg.framework/Cg exist?
does the file /Library/Frameworks/Cg.framework/Versions/1.0/Cg exist?

Ah yes your right the files are not there. Its strage because I have run the DMG. I have also run a past version of the tool kit and still the files do not appear.

I am downloading from

is this the correct page?

have you run the file within the dmg as well? opening a dmg gives you a folder on the desktop that contains a file that you have to tun…

apologies as my last message was not clear.

Yes I have run the installer inside the DMG entered my password and waited for the installer to complete. The installer confirms that it has completed however like I said the files do not appear in my frameworks folder.

You can eigter get a different installer or extract the Files manually from the installer. Cant Tell you how right now, but i did it once as well

Ahhh yes working now so here is what I did incase anyone runs in to the same problem.

The problem is that the CG Toolkit .dmg installer seems to be broken. I ran 2 different versions of the installer and both seemed broken on MacOSX 10.5. So you will have to install by hand.

Right click the file in the DMG and click show package contents. In here you will find the framework files and the bin files you need to copy over. Copy them to the correct paths and re run your test. Works.

Thanks for your help guys!

Works fine