Panda is not useable with Linux.

Hey please if you fix the problem post it here :slight_smile:

of course we will post a solution (if there is one G)
@sm3 dont hurry… i’m going to bed anyway. its rather late and i have to get up early tomorrow.
by the way… for me it looks likethe modell-file data and the uv data is messed up somehow. those models looks like the vertices are forced into a lossy raster or something like this. or the vertex positions where just read out wrong. the greeting card works quite good and this one is a bam file. all other are egg so i could imagine that this bug is hidden somewhere between file format and the part of the engine which is supposed to read bam files.

. not shure thats just what i could imagine out of the blue sky. gess this matrix error is far out of my knowledge.

jup… just like i thougt…

if you rename the old.****.bam.old files to normal bam files and rename the egg to something else its working fine, textures and animations… but i dont think this will fix the matrix error in the other samples.
anyway. the bug is just in egg files. so bam can be used to do your stuff.
i hope it isnt too difficult to fix this bug anyway

Well, my install is finished and I have no problems with it. I ran ppython and it works with no issues.

I also learned that they’ve built Panda off the installed /usr/bin/python. I’ll play around with it a little more.


well. that might be a problem because i updated my hole system and i bet pyhton was updated , too. perhaps there is a version missmatch or something like that…
can you try to update your system (or phyton) and see if its still working after reinstalling panda? maybe that gives us a few mor informations
gess you could use yum to get the phyton update.

Sure, I’ll do the updates now.

It is strange to note that there appears to be no support for Tkinter with FedoraCore3. I thought Panda needed Tkinter. In Windows, I can do this:

from Tkinter import *

but I get an error in fedora core letting me know there is no module named Tkinter. I guess you can install it from CD, however, it doesn’t seem to be installed by default with a generic desktop or workstation install. I believe RedHat uses pygtk instead for their python gui.

This is obviously not your issue, I’m just stating this incase anyone else has a comment about that.

Oh, dingdangit. I just realized what your problems are.

This is a problem with Panda running on international versions of Linux. We already discovered it here in this thread:

There’s a fix checked in for future versions of Panda, but it hasn’t been released yet. In the meantime, the workaround is to type this command:


in the shell before running Panda.


man this is great =)
thx a lot for the link… i never thougt that THAT could cause problems…
god thing i didnt reinstalled everything…
thx thx thx again

Wow, excellent. That is good to know!

I’m hoping your all set now thommy.


Yes indeed, everything is working perfectly now. From the planets to my sphinx and its terxture. Thanx a lot. Development can start ! :smiley:

well. there are still some things^^
after installing Tkinters via apt a few left errors disapeared but it still remain this one when i try to start the scene editor

it would be really cool if someone know how to fix this.
thx a lot :smiley:

Case-sensitivity issue. The SceneEditor is exclusively developed on Windows, so the developers don’t always notice when they put the wrong case in an import statement.


from SeGeometry import *


from seGeometry import *


well thx for the hint… there where about 5 more wrong letters…
now it chanched a bit
todays special error menue, databarbecue with missing color:

rc/tkwidgets/", line 484, in setBackground
  File "/usr/lib/python2.3/lib-tk/", line 1146, in __setitem__
    self.configure({key: value})
  File "/usr/lib/python2.3/lib-tk/", line 1139, in configure
    return self._configure('configure', cnf, kw)
  File "/usr/lib/python2.3/lib-tk/", line 1130, in _configure, cmd)) + self._options(cnf))
_tkinter.TclError: unknown color name "SystemButtonFace"

i installed this tkinter just today via apt.
and i searched the files in the panda directory for this buttonface and there wehere 2 of them. im no prorgrammer but i could imagine of a missing color-definition.

thx again 4 all your support =)

bdw- how can i export a animation without the base-pose in the first frame without getting all animation messed up?

Hmm, you could try changing this to something generic like “Black” or “Gray” in the code.

What are you exporting from? I don’t know about the 3DSMax converter, but maya2egg supports -sf and -ef parameter to specify the frame range of the export. For some other format, it entirely depends on the package and the plugin that you use to do the export, none of which are within our control (or experience).


thx a lot.
color ‘Black’ worked. =) a nice and clean editor… yay thats what i was looking 4 =).
you guys relly rocks^^
actually i wonder why i cant solve such simple problems by myself… guess this is not my best week ever…but its going to be a really good one if those anis where fixed

i exportet my model from Blender (DX8 export) to X file. the mesh is loaded fine with texures and everything, but the time i try loading my modell and animation with pview modell-mesh.egg modell-ani.egg it displays 2 modells.
the animated one is very strange because the first frame has different frame positions than the pose frame of the model (which isnt in the beginning of the ani)

when i try running x2egg -a model-ani.egg model-ani.x
it displays a lot of (gess egg code) but it do not create a file.
i guess its vriting the animation code in the console display instat of writing a file
thats the end of the console output:

<S$Anim> r {
                      <V> {
                        -3.35595 -3.62467 -3.74451 -3.7484 -3.67032
                        -3.52786 -3.36237 -3.18428 -3.0245 -2.90976
                        -2.8425 -2.79804 -2.76451 -2.72702 -2.67966
                        -2.6127 -2.52808 -2.4079 -2.25145 -2.0444
                        -1.75529 -1.40412 -1.03202 -0.669342 -0.324882
                        -0.0236623 0.238676 0.430354 0.537536 0.533194
                        0.383693 0.105813 -0.282172 -0.747386 -1.28563
                        -1.87042 -2.4924 -3.10883 -3.64701 -3.96767
                        -4.01285 -3.83042 -3.50529 -3.09113 -2.64497
                        -2.18091 -1.7428 -1.33359 -0.959853 -0.636598
                        -0.348659 -0.0762261 0.185094 0.430197 0.668163
                        0.89073 1.0956 1.28442 1.45621 1.59605 1.71299
                        1.80627 1.88311 1.94261 1.99193 2.02904 2.05717
                        2.08394 2.10161 2.12312 2.13379 2.13762 2.13768
                        2.13385 2.12851 2.11766 2.11073 2.11085 2.11079
                        2.12312 2.14448 2.18755 2.23618 2.27964 2.31634
                        2.34364 2.34364 2.31778 2.24699 2.12312 1.92685
                        1.67321 1.38333 1.04805 0.693569 0.310148
                        -0.0791967 -0.488192 -0.898323 -1.29083 -1.7004
                        -2.13105 -2.59152 -3.07795 -3.56578 -4.06209
                        -4.53374 -4.94272 -5.23849 -5.34926
                    <S$Anim> y { <V> { 4.3443 } }
        <Table> body {
          <Xfm$Anim_S$> xform {
            <Scalar> fps { 30 }
            <Char*> order { srpht }
            <S$Anim> y { <V> { 0.0007 } }

… and the output overruns the displays of my console so i cant try if its really the case of wrong output

… i hopefully thing that this relly is the last bug i’ll experience.
if this is solved i finaly can start working with it =).

perhaps someone of the developers should have a look onto the x2egg converter 4 linux.

well thx again for all your support.
(thats what i love about open source… you dont have to wait jears for patches even if you could fix it yourself within minutes^^=D )

If you type x2egg without any argument in a terminal it writes:
x2egg [opts] input.x output.egg
x2egg [opts] -o output.egg input.x
x2egg [opts] input.x >output.egg

Try and use the -o output_name.egg way. Otherwise try to send the standard output to your desired file with >


jeah thats what i did… normal convert works fine…
ok … maybe i got something wrong but this is what i want:
a animated character;
what i thought to do… export the character to X-files (i used a single framed mesh.x and the animations seperated in ani.x
i converted the mesh with x2egg -a -o ani.x ani.egg
and the mesh file the same way… both loaded in pview with pview mesh.egg ani.egg i just saw my modell in standart pose.
loading the snigle files its the same way…
when i tried to export it withx2egg ani.x ani.egg and loading it in pview i can see my modell (heavyliy diplaced ) but with animation… and the normal mesh.ani file in pose mode.
if i add the first pose frame to the animation its playing correct but there are still both files seperatly loaded in pview.

i guess i’m blind but i must have overseen something important (cause seperate files 4 mesh and ani are new to me)

Is it possible that your ani.x file actually contains both model and animation together? If that’s true, then when you load model.egg and ani.egg, you’re loading the model twice: once from model.egg, and once again from ani.egg.

What do you see if you just pview ani.egg by itself?


uhm. good question^^ by just exporting the animation. could this mean only bones? (i actually exportet both time mesh+ bones) one time with ani and one time only first frame… sigh guess i havent relly understood how those models are suppposed to be working.
at least my scriptingfriend could work around this porblem. he took the komplete mesh+ani and splitted it via script.
is there any reference about how modellfiles/boness/ani and so on have to be exporteed and in wich way they are loadet correctly?

I don’t think anyone’s written a complete reference for the Blender -> X -> Panda export pipeline yet–there’s just the Blender page in the Panda3D manual, which doesn’t go into details. If you figure out what works and what doesn’t, we’d love to add your recommendations to the manual!