Panda 1.8 configuration with wxPython


#1

Hi, I’m back :slight_smile:

At least three times now over two years I’ve tried to get Panda and wx to work on my mac (running Lion atm). Doesn’t work.

I’ve installed Panda 1.8.0 and the examples (carousel for example) work. When I run

ppython --version

I get

Python 2.5.6

, so I go online and look for a matching version of wxPython. Unfortunately for me there is only a version for Python 2.6 and 2.7, and the 2.6 version doesn’t work. When I try to import wx after running ppython, I am told there is no module named wx. For the record, the native installation of Python (2.6.4) sees wx just fine.

I am installing Panda 1.8 over an old installation of 1.7.2, which I think is why I am seeing an old version of Python. Panda is not easy to completely uninstall, though…any help is appreciated!


#2

Panda 1.8 should be running with python 2.7

Can you try:

import sys
print sys.executable

and check that you’re actually running the correct python?


#3

When I run that in ppython, it says “/usr/bin/ppython”.


#4

Welcome back… :smiley:

So, why aren’t you using Lion’s Python? I also have Lion, and it looks like I can run Panda with its Python 2.7.1, so you should be able to use it with wx.

Here are some hints to uninstall Panda. Anyway, I’ve only installed Panda 1.8 on my Lion and ppython still says that its version is 2.5.6, so you’d better try using Lion’s 2.7.1.


#5

My understanding and experience is that the standard Python installation doesn’t see the Panda libraries, hence the need for ppython.

That’s actually the exact page I used to “uninstall” 1.7.2 before putting 1.8 on my machine. I don’t think that’s all there is to it because my ppython still thinks it’s 2.5 :confused:

Yeah it seems like a catch-22: wxpython needs python 2.6 but python 2.6 doesn’t see panda so using python 2.6 isn’t an option.


#6

The Panda3D 1.8 SDK for Mac is compiled against Leopard’s Python 2.5, sorry.


#7

Ok I’ll do development on Windows then, thanks.