Panda 1.6.1 for Ubuntu 9.04 -

Hi, downloaded and installed the 1.6.1 for Jaunty from the Panda website. Now when I run a test file in /home/mname/Programs/panda3d/mystuff/ I get this:

Traceback (most recent call last):
  File "", line 1, in <module>
    import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

But when I run the same file from /home/mname/Programs/panda3d/ (panda home folder) I get this:

DirectStart: Starting the game.
Traceback (most recent call last):
  File "", line 1, in <module>
    import direct.directbase.DirectStart
  File "/home/yuri/Programs/panda3d/direct/directbase/", line 3, in <module>
    from direct.showbase import ShowBase
  File "/home/yuri/Programs/panda3d/direct/showbase/", line 10, in <module>
    from pandac.PandaModules import *
  File "/home/yuri/Programs/panda3d/pandac/", line 1, in <module>
    from libpandaexpressModules import *
  File "/home/yuri/Programs/panda3d/pandac/", line 1, in <module>
    from extension_native_helpers import *
  File "/home/yuri/Programs/panda3d/pandac/", line 75, in <module>
  File "/home/yuri/Programs/panda3d/pandac/", line 69, in Dtool_PreloadDLL
    raise ImportError, message
ImportError: DLL loader cannot find libpandaexpress.

I’m running python 2.5.4, and I’ve put the panda3d.pth in the /usr/share/python2.5/site-pckages/ dir (it contains one line with the panda3d path)

Any suggestions?

Panda 1.6.1 for Jaunty is built against Python 2.6, which is the default on Jaunty. You can’t attempt to use it with 2.5.

I started this whole thing to learn Python and I already hate it :confused: I don’t remember actually uninstalling python2.6 from the system, although I had to do some fixes in order to make Blender work with it. and now python -V shows that the current version is 2.5.4 How do I make it use 2.6? Thanx

Install the “python” package in the repository.
I don’t have a clue how you were able to make 2.5 the default.

If that doesn’t work, you can also just run “python2.6” instead of “python”, or even symlink it back.

You hate it because you are annoyed by language features like the fact that whitespace matters, or because you were stymied by having the wrong version installed? The former is a perfectly sensible reason, but the latter seems to me like a rather silly reason to hate Python.

Woooohoooooo!!! It works!! (ran it with python2.6)
Thanx a bunch!

I actually love the fact that you have to indent your code (tell me you like reading unindented code).
I installed Blender yesterday, and wanned to use the GE. Had **itloads of python version incompatibility issues which were finally fixed.
And now again was this version thing AND the fact you can keep 293830734 versions of the same language on one puter (which can be good also - but is very very confusing)

So, now that all works, fresh start with Python :slight_smile:

Oh I hate unindented code too; coincidentally, just last week at work I was trying to maintain some code by a crappy programmer whose indentation was terrible, no consistency at all, and I was going nuts. I happen to like Python a lot, I was just noting that’s a reason a lot of perfectly sensible programmers will cite.