Panda 1.3.2, Pyscripter problems

Hi all, I try to use Pyscripter with Panda 1.3.2, but I have so many problems :

If I install just Panda 3D and Pyscripter :
Pyscripter don’t work, I have some error message (“no module named code”,…)
Panda 3D + Pyscripter + Python2.4 :
I set the panda.pth like the tutorial, but it’s not work, “no graphic pipe available” (the config.prc is not found certainly).
I try to change the path of the python interpreter (to the interpreter in panda directory) but nothing happens when I run.

The greetings cards work, my project works with a .bat to launch him (but I really want a good IDE to works)

It seems that Pyscripter don’t work with the Python in Panda3D, but Python 2.4 don’t found the config.prc, can you help me please ? ^^

(sorry for my approximate english :angry:)


EDIT : I’m using Windows XP

Pyscripter specific problem. Don’t ask me.

I doubt that is the problem, but anyway.
Config.prc is located in /etc/ on linux, on windows in c:\Panda3D-1.3.2\etc.
It’s Config.prc (with capital C), not config.prc.

Try just using a text editor, and just type in a command line:

cd "/path/to/yourfile/" (replace / with \ on windows)

That ought to work.

Nothing wrong with P[size=75]ANDA[/size]3D then. If GreetingCard works, you should be able to run your own .py file, too.

Uh… What do you mean? Do you want to create a .bat file for your application?
In that case, create an empty .bat file, and edit with your favorite text editor, and enter just this:

ppython.exe ""

It’s that easy. [size=84]For a linux shell script, remove the .exe, and save it under the .sh extension.[/size]

Try Eclipse with PyDev.

No idea why it wouldn’t.

You mean the P[size=75]ANDA[/size]3D libraries. I have no idea why it wouldn’t find the Config.prc. Are you sure that is the problem?
Did you compile P[size=75]ANDA[/size]3D by hand or did you use an installer from the download page here?

No problem.

No problem.

Thanks for this rapid answer ^^

The Config.prc is here, on etc, and the Panda projects works fine, my problem is to use Pyscripter with Panda

I have already try it (not with Panda3D), I don’t want to use all my CPU for this Java thing…

I just want to say that’s not a bug in my project, I use a bat with a pause to debug, but it’s really not productive

Maybe because the python in Panda is not “register on the system” like the original python.

The shortest way to solve my problem is to find how I python2.4 can find the Config.prc, so it may work.

EDIT : I’m using Windows XP

I assume you want to use PyScripter’s internal Run (f9) and debug commands, instead of the external one.
After trying many things, I believe that Panda looks for “etc” directory relative to the executed python.exe. Meaning, since PyScripter runs it’s own built-in python interpreter, Panda would look for “etc” in PyScripter’s directory. Then I copied “etc” and “models” dirs from Panda dir into PyScripter’s dir.
Well, it works, but it gives me another problem.
PyScripter gets crazy. It ran only the 1st executed script file correctly. If I load another script, which is not in the same dir as the 1st one, it wouldn’t run due to current working directory which seems always stick to the 1st executed file. Though I have checked it using os.getcwd(), nothing was wrong, but it seems PyScripter’s built-in python interpreter’s working directory didn’t updated. I’m not sure this can be solved by using Run’s command line params, though I’ve tried and no changes.
Meantime, I restart PyScripter after opening the other (different dir) script. :confused: :angry:

Thanks for your search :slight_smile:
So, I just can change my IDE :angry: