packpanda :-)

Hy PandaPeople

I’m try to pack my demo in pandapack. My command is:

pandapack --dir “Kill_Monkey” --name “WannaKillAMonkey” --version 0.0.1 --bam --pyc --fast

The name is just illustrative … i love monkeys :slight_smile:
They compile gently and make my exe.

Well i install my program, ok!
When i run my game don’t run :frowning:
And my distro is about 100 megas (!!! hey is just a 10 k of code, i expect a increase of size about the libs, .dlls and more, but…)

Whatta a heck :unamused:

from the manual

if you force packpanda to not use good compression you shouldnt be surprised if you end up with big files :wink:

i dont really know why your game fails to run. are you getting any errors?

Window quicklly close the window… i can’t see the error Message. I’m search for some log, but without success for now.
I’m trying without fast now…


After pandapack i receive 7 warnings:

7 warnings:
uninstall function “un.RemoveFromPath” not referenced - zeroing code (232-305)

install function “AddToPath” not referenced - zeroing code (2931-2971) out

install function “RemoveFromPath” not referenced - zeroing code (2971-3044) ou

install function “StrRep” not referenced - zeroing code (3081-3119) out

Variable “READABLE” not referenced, wasting memory!
Variable “MANPAGE” not referenced, wasting memory!
Variable “TUTNAME” not referenced, wasting memory!

I don’t know wherever about it.
My compressed installation file is about 23 mega but when i install my demo become 100 mega (gee!). This is normal. It seems it install panda-python and my code all together. This is normal?

Still my game doesn’t work :confused:


I change my code and put some try… excepts and os.system(pause) to stop executable and send error messages without close.

Who’s guess the error message?

Assertion failed: okflag at line 106 of c:\p\panda3d-1.5.4\built\include\virtual
okflag at line 106 of c:\p\panda3d-1.5.4\built\include\virtualFileSystem.I

The same error from my previous subject about py2exe :wink:

Well, i guess i’m in dead end.

It just means it can’t find your .ptf file. Is it part of your packed archive? Does it end up in the install dir when it unpacks itself? Are you loading it with the right path to find it in the unpacked install dir?


Hi david

You’re right, my .ptf was bad referenced. I change it and packpanda again. Everything runs fine but whe i run the game i receive a “pphyton have a problem and must be closed” from windows :frowning:

My code got particles and glow filter, these resources are incompatible?

I don’t know of any incompatibilities there. Must be something else.



Besides in my test code i can use particles and glow filter or normal map when i pack both seems incompatible.
I disable glow filter and runs fine.
Just for test in my code i put render.setShaderAuto() in my code and pack it again. Then i got:

“Shaders don’t support Matrix yet!”

Likewise if i alternate the resources they run fine (particles off, glow on // particles on, glow off … same with normalmap)

Thanx :smiley:

Hmm, it runs fine when you run it directly, but not in the packed version? That seems strange all right.


I guess i´ve same error message when i try a textureHorzOffset in a Texture stage with normalmap (to make a fake water).

My particles render sprites. They don´t have normal map…
Well i don´t know at all :slight_smile:

Thanx for help David