P3D Web Object

Hello, I am still somewhat new to Panda3D and I was trying to see what method people use to easily display their projects. I turned my project into a P3D, have it on my website, and it seems to be working just like when I run it in terminal. However I noticed that it only seems to work on my computer. (Although I’ve only tested two other computers so far).

Do other people need to have Panda installed to be able to see it? Also I used a self-generated certificate, I’m not sure if that would affect whether or not other people can see it.

It is currently at this website:


Here is the source code: (I wrapped with comments to display here)

They need to install the panda3d runtime (link is in the download page).

You can link people to one of the the following URIs to install the Panda3D runtime:

PS. The application you have on there is very interesting!

Ah, well hopefully people are willing to download that when they visit. Thank you

I added the first link rdb posted (2 posts up) to the website and tried it from the other two computers I mentioned earlier. Both of them are Max OSX (10.5).

On the first computer I downloaded Panda3d Runtime, installed it, went back to the website and it did nothing in Safari. In Firefox it ran an installation in the browser window and then worked. (It also worked in Safari and Chrome after that Firefox installation).

On the second computer I also downloaded Panda3D Runtime and installed it but nothing seemed to happen in Safari or Firefox.

The installation just happened automatically the first time around, anyone know how to make the installation happen in general?

Hm, could it be that you didn’t restart Safari after installing the Panda3D runtime?

That was exactly it, thank you again.

One last thing, the installation ran in the browser window and it worked on the second computer in Safari but not Firefox. It worked on the first computer’s Firefox though. Are there specific settings in Firefox’s preferences that would block Panda?

How do you define “not work”? Does the window stay blank? Does it display the error image?
Is there any error message in the logfile in ~/Library/Caches/Panda3D/log after trying it in FireFox on the second computer?

By not work I mean that the text in the website is at the top of the page as if the Panda window wasn’t even there.

I opened the log files (to be honest I don’t know what those are) and looked at the syntax in them and there didn’t seem to be anything about errors.

Any guess?

Does the Panda3D plugin even show up in “about:plugins”?

Where can I check that?

Type about:plugins in the address bar of your browser, and see if the Panda3D plugin is mentioned on the page.

If so, please do pastebin the logfile(s) that you found in ~/Library/Caches/Panda3D/log/.

The plugins include Panda3D and it is enabled.

I also do not know what a pastebin is

I had someone else test it on a Mac OSX in Firefox and it worked without me helping them. Really the goal was just to be able to see it online with little hassle, I’m going to assume that second computer just has some bizarre setting that makes a problem in Firefox.

Thank you for all the help

Ah, there is a bug in Firefox for PPC that causes it not to be able to run the Panda3D plugin. It appears to be a bug in Firefox itself, not in the plugin; our code never even gets called.

It works fine in Firefox for Intel.