No suitable FBConfig contexts available

I just installed Panda3D on Ubuntu 12.04 and only the Asteroids sample worked. The rest gave me a blank screen and this error message:

Known pipe types:
  glxGraphicsPipe
(all display modules loaded.)
:display:glxdisplay(warning): No suitable FBConfig contexts available; using XVisual only.
depth_bits=24 color_bits=24 alpha_bits=8 back_buffers=1 force_hardware=1

How do I solve this error?

This should be just a warning; it’s supposed to work anyway. However, it hints at the fact that your graphics drivers may not be working as well as they should. Try updating them to the latest version.

PS. This thread really belongs in the Installation forum.