No graphics pipe is available error while converting to .exe file

I have recently competed my first 3d game in panda3d!
I exported my .py to .exe using the methods given in the Manual
i got the exe file but when i run it i got an error

:display(warning): Unable to load libp3tinydisplay.dll: Not a valid Win32 application
Known pipe types:
(all display modules loaded.)
Traceback (most recent call last):
  File "__main__", line 18, in <module>
  File "direct.showbase.ShowBase", line 339, in __init__
  File "direct.showbase.ShowBase", line 1021, in openDefaultWindow
  File "direct.showbase.ShowBase", line 1056, in openMainWindow
  File "direct.showbase.ShowBase", line 766, in openWindow
  File "direct.showbase.ShowBase", line 746, in <lambda>
  File "direct.showbase.ShowBase", line 818, in _doOpenWindow
  File "direct.showbase.ShowBase", line 647, in makeDefaultPipe
  File "direct.directnotify.Notifier", line 130, in error
Exception: No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

i look at other solution in the community, but i did not understand some stuff(because i am not pro like the others), and other methods did not work.
There is no error while running the python file, the error only occurs during when i try to run .exe file.

and here is the config file:

framebuffer-srgb true
textures-power-2 none
show-frame-rate-meter true
show-scene-graph-analyzer-meter false
audio-library-name p3fmod_audio
icon-filename Icon.ico
fullscreen false
load-display p3tinydisplay

i have added the “cg.dll”,“cgGl.dll” files, and also the two config file(“Config.prc”,“Confauto.prc”)

If somebody had the same problem as mine and had found solution in the community, plz post the link here.

You need to add the p3tinydisplay plugin in your file.
Have a look at this for all the available plugins.

Something like this:

"gui_apps": {
"plugins": [

Alen Savio, is it your intention that your program use the “tiny display” renderer?

If so, then the preceding post may help.

If not, then I don’t recommend using the solution given in that post: the “tiny renderer” is rather slow, as I recall, and thus the performance of your program may be significantly reduced.

In which case, could you post the “” and “requirements.txt” files that you (I presume) used in building your program, please? There might perhaps be a clue in there as to what’s going wrong.

Oh! thanks for the tip😇.
this is my file before creating this topic:

from setuptools import setup

    name="Test Game 01",
    options = {
        'build_apps': {
            'include_patterns': [
            'gui_apps': {
                'Test': '',
            'plugins': [

and requirments.txt


These are my and requirments.txt.
I tried converting a simple panda3d app that does nothing(not even load a model), as a test, but the app worked with no error!
i Think it maybe because i did not add all the plugins.(I didn’t know about these plugin stuff, because i came from the world of unity, and when we add plugins in unity projects, it is automatically added to the final product, but i love this game engine that’s why i switched)
i will be also trying to find out what i missed.

Oh! i did not know there was a full page about these plugins. Thnx for letting me know.:innocent:

I got it working ,
i tried running the setup file one more time after restarting the PC .
Now it is working! Yay!:heart_eyes:

1 Like

In any case, it is preferable to use the pandagl plugin for rendering. Also note that the p3fmod_audio audio plugin must be purchased, since it has its own license. You can use only p3openal_audio for free for audio


I think that I read somewhere that FMod did make some change in that matter, perhaps specifically for devs with budgets below some threshold, or some such. There is indeed a potential concern there, I do believe, but it might be worth checking the FMod website.

I checked the license, however, there is a commission for indie of $2,000. The only exception is for educational purposes and a non-profit project.

Ah, there you are then–I stand corrected!