New Installation

When trying to verify my installation, I attempted to compile the sample “Hello World” program from the manual. After a bit of tweaking, I was able to get all my settings correct and my blank window will now show up and run properly. All except one part: the title. I am getting weird corruption where the title should be.

This is the title:

I hope someone can shed some light on this. I have verified that the text in set_window_title in my code is “My Panda3D Window”. If I change that (I thought initially that it may be an error parsing the space in there) to a single word like “None” it simply doesn’t show a title at all. I can post my code if anyone wants to see it, but it’s only the sample application from the manual.

I’m on Windows 7 Ultimate x64 (I have Unicode fonts and East Asian support enabled as I work in Japanese as well, but I don’t think this is the issue) and I’m compiling with Visual Studio 2010 Express.


Oh yeah, I forgot to mention that I did indeed build via RELEASE (in fact, I got rid of the DEBUG configuration entirely) and I verified that the NDEBUG directive is not set. Those seem to be the top suggestions in the threads I found, so I checked them first.


Does nobody have any information on this? If nothing pops up by tomorrow evening, I will continue my project, I am just afraid that this may only be a visible symptom of a much deeper problem. Is there a chance that it’s just because I’m on VS2010? Or on Windows 7? I have seen other posts on the forums that have had success compiling on each of these. Is it perhaps the combination of Windows 7 and VS2010? Any help would be appreciated.

~ David

Hmm, this might be related to a problem reported by another user, whose Panda3D installations would crash every time he tried to open a window. He was also running on Win7 64. Maybe there’s something different about the way Win7 accepts the window title?

Other than that, I’ve never heard of this issue before. :frowning:


Thanks for the info. If any further information about my system configuration would be useful for troubleshooting purposes, feel free to contact me!

If I come across any other odd behavior, I’ll be sure to report back! Thanks again!

I run win7 64 everything works as expected. I think its deeper then that.

Which compiler are you using? Which edition of Windows 7? (Ultimate, Basic, etc.) Somehow, we should be able to narrow this down a bit. I can post the code I have, but it’s just copy-and-paste from the tutorial in the manual, so I don’t think there’s an error in there.


I’ve also been having trouble with panda on Win7. I’m using home premium. I haven’t got around to building panda from source yet, but can’t get any of the samples to work, either as standalone apps or using the browser plug in. For more details I have a thread on this forum called “python.exe has stopped working”.