Need testers ASAP! (Linux/Mac)

I need some help from all of you. I’ve made a demo for a game that I will be raising funds for any day now, but before I make it public I’d like to know if it even works on anything else then the two PCs me and my teammate have.
The task is simple - click on one of the links below, download the demo, run it and report back:
Linux (AMD64):
Linux (i386):
OSX (i386):
OSX (ppc):

Screen of what to expect:

The demo need a fairly modern computer, there’s normal mapping, soft shadows and bloom. If it starts, but runs at ~3fps then there’s a config.cfg file that can be of some help, all the valid options that cen be in a prc file can be added to this file, the extra options are

soft-shadws 1 or 0
on/off for soft shadows (…I know, theres an ‘o’ missing)

shadow-map-size 1024

the size of the shadow buffer (should be power-of-two)

antialias 1 or 0
on/off for antialiasing (multisample)

terrain-detail 3
from 1 to 5, the higher the number the more tessellated (smoother) the terrain and the longer it takes to load it

terrain-normalmap 1 or 0
when set to 0 a simpler shader is used that doesn’t use normal maps for the terrain

bloom 1 or 0
on/off for bloom (the first thing I suggest to turn off)

Oh, and a word of warning: the character is naked under the cloths and you can strip her, so don’t do it if you don’t want to see nude pixels :unamused:

WSAD to move, right mouse button to stop/start camera control, mousewheel to zoom in/out, to equip items click an item and then click n the slot you want it equipped (slot must be empty). Enter allows to input some chat messages.

Hi wezu, I’ve tried it on a Snow Leopard MacMini and it works like a charm. Gratz, it is cool so far! :wink:

60 fps with all the option max (800x600 resolution) on my old laptop (Ati Raedon HD 4650)
Sometimes some fps drop to 55fps.

Edit: Test on windows

Impressive work :slight_smile:

Tried on my two computers, which are sort of aging.

Windows 7
Q6600 2.4GHz
GeForce 8800GT

Full settings, 60FPS. Tried 1600x900, 60FPS still.

Ubuntu 12.10
2 GB Ram
GeForce 9400M

Max settings: 17-19 fps
Bloom off = 12 fps (?!)

None of the other settings really increase frame rate, got about 5fps extra by settings texture-scale to 0.25. Of course that makes the ui terrible :slight_smile:

Max I got was 22 fps.

Thanks, that’s really helpful.

The frame drop from turning off bloom must be the side effect from anti-aliasing, with bloom on there’s no AA (or I’m doing something really stupid). The texture-scale gave me an idea, I should keep all the gui textures with a “gui_” prefix so I can exclude them from a texture-scale setting… and I should pack anything else in dds to save some texture memory.

Linux Mint 14
ATI HD 4850, AMD Phenom II x4 960T

~230 FPS on an empty road
~130-160 FPS in the villadge

Also, as I can see, you not used the mip-mapping (or may be something wrong on my system) and when I move around it’s causes a jitter and ripple of the texture

I’ve set the the filters to nearest on some normal maps to make them look sharper, as far as the terrain goes … it looks really bad with anything else then linear

Top row: linear_mipmap_linear on the left, linear on the right
bottom: the same with texture-anisotropic-degree 4

You can test it yourself, just add ‘texture-minfilter linear_mipmap_linear’ to the config.