my p3d exe not running

I’m sorry to bring this topic up again, but my game doesn’t run.
The p3d file was created using packp3d, but when I ran the exe, the application closes.
I am wondering if it is missing some files, since my model files and sound files are in separate sub-directories in the main folder containing the
I have been checking through the manual as well as the additional options in packp3d but I find nothing that would allow me to manually add these folders. In fact I saw this:

…which seem to indicate that I don’t have to worry about my model files being is sub-folders.
Any suggestions on why my game isn’t running? (It runs well from the .py) Thanks

Did you check the logfiles?

Yes. It just showed 5 errors which I took note of, but they were only missing texture files, which doesn’t prevent the program running. The models just appear gray.

What happens if you run the p3d file?

Can you post both complete logfiles (i.e. at Does it close the app gracefully or does it crash?

I’m sorry. I was otherwise engaged and did not check in here for a while.

The black window opens, and then then closes (just as it opens).
Sorry, I didn’t save the log files.

There are already logs for the runtime (located at runtimedir/log).

You should also add logging for your application.

And you could redirect error messages to files in order to show them if helpful, with something like:

sys.stdout = open( 'yourApp_report.txt', 'w' )
sys.stderr = open( 'yourApp_errors.txt', 'w' )

Without error messages it’s impossible to help you, because in “normal” situations the deployment tools of Panda work correctly.

Ok thanks.
I’ll read up on those threads and send the log file in my next post, but right now I discovered I have another problem.
I just discovered that my panda3d folder was empty, also my panda3d-1.7.0 folder bin was empty except for the packp3d file.
How that happened is a mystery to me, unless it was the result of hackers activity.
I reinstalled both programs and tried building the game again, only to get this:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Jaguar>cd c:\panda3d

C:\Panda3D>packp3d -h

C:\Panda3D>packp3d -o myGame.p3d -d c:/panda3d-1.7.0/game


This is frustrating!
I have the same packp3d plugin I used before. In fact I even upgraded to the newer one.
Why doesn’t it work like before?
Help please. I did not expect to spend so much time on this.

Have you tried upgrading to 1.7.1? The issue might be fixed there.

I haven’t been able to download it yet, since I have a slow connection and usually have to ask a friend to get big downloads for me.
In the meantime, I will try ppackage and see how that goes.

By the way, I searched my computer for the log file and found none. I’m guessing it was erased with the other files. Thanks