multifile error

Hi :slight_smile: I’m new to Panda3D and am trying to check it out, but I hit a (really dumb) problem right from the start ._.

I’m trying to follow the tutorial at … sy_Scenery .

I have the feeling I don’t have the model required… (where do I download it?)

But anw… what’s weird is when I try to run the program (cmd, ‘panda3d’), I get the error:

:express: /d/Program Files (x86)/Panda3D/ is not a Multifile.

I tried going back to the first link, tried removing the line requiring the model, and nothing fixes it (short of running ubuntu or restarting my computer). Am I (possibly) running a wrong version of panda or something? Cos when I look at the installation folder there are a grand total of 9 items lol. Seems a bit little (and again, I am new to python in general).

WHYYY :frowning: How do I fix this? From what I googled, I’m not exactly sure what multifile is but I am pretty sure it’s not what I need here…?

The command you’re looking for is:


The command “panda3d” is used to run apps that have already been packaged into a p3d file, which is a kind of Panda3D multifile. For Python source code (which ends in .py), run it directly with the Python interpreter.


Oh wow, thanks for the reply! Got it. But now I got another error, something about “no module named showbase”.

I installed panda3d to D:\Program Files (x86)\Panda3D, and I have a panda3d.pth file at D:\Python27\Lib\site-packages that says “D:\Program Files (x86)\Panda3D”. Is this wrong? :confused: I don’t see a ppython anywhere that I can use… and my python version is 2.7.3. How do I fix this? Am I doing something wrongly? I downloaded the installer a few times and reinstalled it but it still doesn’t work.

Welllll this is awkward hahah I think I downloaded the wrong version. Thanks David for your help!