MoPath curves not working, problem with new exporter?

Hi guys,

I am working with motion path curves in maya, and I just tried using the new mayapandatool and for some reason motion paths are not working any more. Can somebody else try to create a motion path from a curve and tell me if it works?

Exactly the same method worked before with mayapandatool3.mel

I just created a vertical CV curve, export it as a mesh, and here is what the egg file contains :

<CoordinateSystem> { Y-Up }

<Comment> {
  "maya2egg2008 -a model -o C:/Panda3D-1.5.3/models/mine/test.egg 'C:/Documents and Settings/Doros/Desktop/Game engines/panda 3d/maya models/island/test_temp.mb'"
<Group> test_temp {
  <Dart> { 1 }
  <Group> groundPlane_transform {

Any help appreciated. Thanks

p.s the reason i moved to the new panda tool is because of some limitations with the old one. If I create a curve with the old one, and then somehow motify it, any changes I do will not be exported into the egg file. Anyone else had this problem?

oh and I am using maya2008.

It’s because the “-a model” option given to maya2egg. That “mesh” export option in the original mayapandatool exports the mesh as animated character, since the day it was created years ago, until v1.5.3.
A curve can’t be exported as a character.

Are these references correct to you :
old one : my mod (mpt3)
new one : v1.5.3’s

Really ?
What happen if you delete the egg first before export ?
Is there any error message in script editor output ?

PS. : there is nothing new in the v1.5.3’s mpt, but correction of the maya2egg version name calling, which is already done months ago in my latest mpt3.

ynjh_jo thanx for your reply.

I have solved the problem by using your mpt3, and selecting model/DSC flag instea of all in the save transformation. Now the changes in the curves are reflected in the egg file.

Thanks for creating the mpt3 btw!


Hmm, can this be classified as a bug in Panda’s exporter? If so, I’d think we need to fix that…

Funny, I can get it exported correctly, even with keeping the transforms.
I’m using 1.5.3.