memoryHook still cousing greaf for my testers!

Every time some one tests 2aw they get this assertion error at some points of its execution:

Assertion failed!
Line: 44
(int)size <= _requested_heap_size

1 Could we compile it out of 1.5.4 ?
2 Can we print assertions to standard error instead of popping up a dialog box on windows? Its really really annoying.
3 Can we fix it the right way? Its tied to the loaded of cached bam files because removing those fixes the problem. Assertion happens only on model and texture load calls.

  1. It’s already compiled out in 1.5.3. You must be using 1.5.2 or earlier.

  2. Most assertions actually raise a Python exception, but this is extremely low-level code, which appears before we’ve even defined the mechanism to interface to Python, so all it can do is fall back to the system assert() call, which does whatever it does. By design, though, an assertion is not supposed to be triggered. It is of course a bug that this one keeps coming up; it’s a bug that we haven’t solved yet.

  3. If you have the right solution I’d be happy to apply it. In the meantime, we’ll have to leave it commented out. It doesn’t seem to cause major problems with the check commented out (it just means the pstats memory reporting goes wonky sometimes).


I made sure that my testers are using 1.5.3 and no other panda3d libs are installed on their computer i still get this:

what i don’t get is why the odd C:\p3ds path??

Well, as you can see here, under the tag “panda3d_1_5_3”, not only is the line in question commented out, but it isn’t even line 44 anymore (it was line 44 under the panda3d_1_5_2 tag, though).

So, either you are somehow running 1.5.2 after all, or the tag is inaccurate and the 1.5.3 build isn’t actually built according to the panda3d_1_5_3 tag.

MSVC preserves the path that the program was built under. So whoever built this version of Panda must have done so under a directory call C:\p3ds.


To be certain, you can check if C:\Panda3D-1.5.3\include\memoryHook.I really has the line commented out or not.

yes you guys are right. My testers got the panda3d 1.5.3 from some place else it also had the CVS dirs on the python folder. Downloading the real 1.5.3 fixed the problem. Thanks alot!