memory error while running examples?

I’m a newbie with PANDA3D, and I get some weird problem:
After I installed the PANDA I tried to run the examples, but I got error report and be forced quit every time with each! It processed something for a while and then told ‘The instruction at “0x04252b84” referenced memory at “0x00000010”. The memory could not be “read”.’

(I’m in a Chinese system so I didn’t snapshot the content of error. )

And I mentioned the error was happened in python.exe so I tried with the follow ways:

  1. I installed the python 3.1.1
  2. I re-installed the directX 9.0c
  3. I try it on a clear virtual system with Virtual Box(I happened set-up a new system win XP this week)
  4. I created a project in VisualStudio2005, following the tutorials “A Panda3D Hello World”, compiled and ran(I have set it in “release” mode).

None of those worked! :frowning: With the 4th way, I got a error with different memory address:
The instruction at “0x03582b84” referenced memory at “0x00000010”. The memory could not be “read”.

I searched the forum and google but found nothing talking about this. So I’m very eager to get any suggestion for I spent 2 days on this.
With my best appreciation. :slight_smile:


Well, if the samples don’t work, then compiling your own application won’t work either. So let’s get the samples working.

First, Panda comes with its own version of Python, and that happens to be Python 2.5. Installing another version of Python won’t help, and might actually cause problems. Make sure you are running the python.exe that comes with Panda, and not any other python.exe.

Can you run pview.exe successfully, without crashing? If you cannot, then the crash problem isn’t related to Python at all, since pview.exe doesn’t use Python. Maybe it’s your graphics driver. You could try downloading a newer graphics driver from your graphics card manufacturer. Alternatively, you could try running in DirectX, or even in tinydisplay software mode, by editing your Config.prc file, and replacing the line:

load-display pandagl


load-display pandadx9

if that still crashes, try:

load-display tinydisplay


Hello again,
And while compiling the code in this page,, the “nout” caused “LNK2019: unresolved external symbol” error. Normally this means I used some “wrong version” LIBs? Is this caused by python too? I do not touch python before.
Thanks again!


Thank you David! But with both pandadx9 and tinydisplay the same error came out again. “pview” the same.
There are 3 lines about load-display:

load-display pandagl
#load-display pandadx9
#load-display pandadx8

And I just replace the pandagl in the first line, then save and run. Is it right? I guess the #blahblah should be annotation.

p.s. If this will help, I’m using ASUS lap-top with nVIDIA geforce go 7700.

Thank you again!


Well, hmm. If you’re still crashing in tinydisplay, it can’t be a problem with your graphics drivers. And if you’re crashing in pview, it can’t be a problem with Python.

The only thing left is some conflicting DLL on your path, from some other software package you have installed. Try clearing your PATH variable of all other contents except for Panda. Also try running pview from the same directory that contains all of the Panda DLL’s.


Thank you David,
I just installed the newest graphic card driver, and the pview works! Why I didn’t try this earlier, and the downloading from nVIDIA is so slow…

My PATH variable is in confusion indeed so I cleared it. But I recovered it after installing the driver to see if it still work. Since it works well I think the problem is not caused by confliction. And about the PANDA dll folder, is it “panda\bin”? The pview.exe is right there in default.

Thank you for all your helpful suggestions.