MayaPandaTool Problem

I am using Maya 2009 and tried to use the mayapandatool.mel file by dragging it onto an open window in Maya and it quits the application. (I’m using a mac)

I also tried the shelf process from the tutorial but clicking on the shelf icon also quits the application.

Any idea on how to make a Maya model into an egg file?

The mayapandatool.mel script relies on the maya2egg command-line tool, which might not be available on the Mac (unless you have the OpenMaya libraries available and can build Panda yourself).


Is there any other way to make models into egg files then?

You can try exporting to some other supported format, such as .x or .dae or even .obj. Each of these formats have their own limitations.

Or, I suppose you could try to run maya2egg under Boot Camp or some such nonsense.


Where can I find the differences between the files? I found where to export as dae in Maya but it doesn’t seem to work the same way as an egg in Panda.

I wrote:

[color=blue]import direct.directbase.DirectStart
from pandac.PandaModules import *

environ = loader.loadModel(“colorCube.dae”)


The model was just 6 cube polygons that were arranged to make one larger cube. (All touching each other) In Panda the top and bottom cubes were in the correct places but the other 4 cubes were a good ways off.

Any ideas how to make it be seen normally?

Where can I find information on how to use those kinds of files? The only one I know how to make is a .dae and it doesn’t seem to work correctly in Panda.

I am using a Mac and Maya 2009 and don’t have access to a PC for maya2egg

I am no longer sure how I made a .dae in the first place and no longer have the first .dae with the vertices problem. I tried to export as .obj but Panda doesn’t seem to accept the file type. After trying a number of different things I managed to trigger this error message:

[color=red]DirectStart: Starting the game.
Known pipe types:
(all display modules loaded.)
:loader(warning): Unable to load libmayaloader.dylib: No error.
:loader(error): Extension of file is unrecognized; cannot load.
Currently known scene file types are:
Bam .bam
Egg .egg
MultiGen .flt
Lightwave .lwo
DXF .dxf
VRML .wrl
DirectX .x
Also available: .mb
Traceback (most recent call last):
File “/Users/asimes/Desktop/”, line 4, in
environ = loader.loadModel(“”)
File “dstroot/pythoncode/Developer/Panda3D/lib/direct/showbase/”, line 169, in loadModel
IOError: Could not load model file(s): [‘’]

I tried to find information on how to make any of the above listed file types in Maya but still cannot figure out how to do it. Any information on how to make a working model file on a Mac would be greatly appreciated.

I figured out how I made the .dae file the first time. I had to turn on the fbxmaya.bundle in the plug-in manager to export my model.

What I made in Maya was a box made out of 6 stretched cubes (The same thing I made last time). In Maya the cubes were touching on their edges to form the box. In Panda the top and bottom sections of the box are in the correct locations but the walls are much higher up.

(To RDB) If you are still willing to look at the .dae I would appreciate it. You mentioned e-mailing it to you before, what address should I send it to?

**Edit: I just noticed your e-mail is attached to your username

I downloaded the latest build bot from and now the model loads correctly.

Thank you to rdb