Maya2egg2008 problems

I’m having a bit of trouble exporting to Maya on win7 64 bit. I get:

Couldn't execute /c/Panda3D-1.8.0/bin/maya2egg2008_bin.exe: 14001

checking the logs shows this:

Activation context generation failed for "C:\Panda3D-1.8.0\bin\maya2egg2008_bin.exe". Dependent Assembly Microsoft.VC90.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8" could not be found. Please use sxstrace.exe for detailed diagnosis.

Does maya2egg2008 not work on 64 bit windows? If not, which ones do?

Thanks in advance :slight_smile:

maya2egg should work on 64-bits Windows, but only with a 32-bits version of Maya. We don’t currently support 64-bits Windows as of 1.8.0, but you can always go ahead and build your own version of Panda.

Thanks rdb. I’ve tried again using 32 -bit maya and the maya2egg from panda 1.7 but running into the same issue. Any idea what might be wrong?

Could you try installing the Visual C++ 2008 redistributable package? … px?id=5582

Worked like a charm! Thanks rdb :slight_smile:

Sorry rdb, I’m trying to get the exporter to work with Maya 2010 now, but getting the output:

Program exited with status 3221225784

I’m using win7, Maya 32bit and installed the visual studio stuff from the previous link. Any other ideas on what I can try?