Maya2egg

So I tried to export from maya to .egg, got this:

Finished exporting (.mb -> .egg)
Exporting scene...
Saved entire scene as temporary file: earth_temp.mb
Using these arguments: maya2egg28 -a model [END]
Your scene will be saved as this egg file: earth2.egg
In this directory: C:/Documents and Settings/Negge/desktop/explosion/

Initializing Maya.

Finished exporting (.mb -> .egg)

But when i open the folder “explosion” there’s nothing there, nothing i temp folder.
Any got a fix for this or know what the problem is?

Where did you copy that from ? The output window, or script editor ?

The script editor

Ok, so I tried thru cmd instead of .melscript.
Here’s what i get:

ImportError: no module name maya.app.python
Invalid Python Enviroment: Python i s unable to find Maya's Python modules
Python Eviroment:
  PYTHONHOME not set!
  System modules located at C:\Python25\Lib
  Python Cannot fin sys module!

FINALLY!, it works now, so for future panda testers here’s what i did:

Copy the folder: C:\Program\Autodesk\Maya2008\Python\lib\site-packages\maya

Paste in:
C:\Python25\Lib\site-packages

AND THEN IT WORKS!!!

Ah. So that is the problem, you were using your own version of python.
Just to note (you might run into other problems): Panda3D comes with its own version of python (2.5), you do not need to install any separate python.
See this page for more info.