maya2egg, newbie doubt

Hi everyone,

Thats my first post in the forum :slight_smile:

I have a doubt that concerns maya2egg exporter, I wish to know if maya2egg is an app installed by Maya, or by Panda3D?

I have Maya installed on my Mac, from where I wish to export the models, but I do not have Panda installed on this computer.


p.S.: please, a Universal panda3d version for MAC! :slight_smile:

hi, and welcome to panda3d.

the maya2egg tool comes with the panda installation.
improved mac support. is currently under development. a beta-version already is available.
it has high-priority and is targeted for the next panda release nubered 1.6.0.
if i remember correctly panda already compiles on intel macs, only a few 3d-party libraries have to be ported

maybe pro-rsoft can tell you more about its current status.

maya2egg is an app from Panda3D. To my knowledge it only works on windows, unless you compile from scratch using the “ppremake” system, and even then I’m still not sure.

You can always compile Panda3D yourself if you are running Mac. Here is a guide: … opard.html
(If you use the 1.5.3 source you don’t need to apply the patches on that page)

I’m indeed working on universal binaries, however, while if you compile it from scratch you might get maya support, I doubt that I will get maya support working in the universal binaries, unless someone buys me a mac and a copy of maya.

The general rule is: if you build from scratch using ppremake, and you have a full version of Maya installed on your build machine (and you configure ppremake to use it), you will build a maya2egg suitable for that particular version of Maya.

So, the way to get maya2egg for Mac is to buy a copy of Maya for Mac and install it, then build Panda against it. The way to get multiple different versions of maya2egg similar to the way we have multiple different versions for Windows, is to buy multiple different versions of Maya for Mac.

That’s the reality of interfacing with closed-source, licensed, and expensive software.


Hi guys, thanks…

Well, I tried to install Panda on my Mac… including following this tutorial pro-rdoft suggested, but it results failure… I will try again and see what happens.

I successfully installed panda on my Linux PC, but the Chicken plugin for Blender, seems not working properly… thus far I couldn’t export an animated model :stuck_out_tongue: That’s why I asked about the maya2egg.

someone could plz point me a way to build Panda “against Maya”, in order to have the maya2egg? any link on web… or something else?


If building with ppremake is giving you errors, please post them so we can help you with them.
To compile against Maya, you’d need to look in the sample dtool/Config.pp and search for Maya; you’ll see that various stuff is defined:

#define MAYA_LOCATION /usr/aw/maya
#defer MAYA_LIBS $[if $[WINDOWS_PLATFORM],Foundation.lib OpenMaya.lib OpenMayaAnim.lib OpenMayaUI.lib,Foundation OpenMaya OpenMayaAnim OpenMayaUI]
// Optionally define this to the value of LM_LICENSE_FILE that should
// be set before invoking Maya.
#defer HAVE_MAYA $[and $[<= $[OPTIMIZE], 3],$[isdir $[MAYA_LOCATION]/include/maya]]
// Define this if your version of Maya is earlier than 5.0 (e.g. Maya 4.5).
#define MAYA_PRE_5_0

In your own Config.pp you only need to override the settings here if they are incorrect for your maya setup.
If you run “ppremake” inside the “dtool” dir, you should get a list of what will be compiled and what won’t – Maya should be in the list too, if not, then your settings were invalid.

Also note that the guide by edalytical is incomplete; it doesn’t compile pandatool, which includes maya2egg.
To fix that, just before the “genPyCode” step, you need to ppremake && make && make install in the pandatool dir as well.


Ok… I tried to install - according to Edalytical tutorial- and I got an error in the ppremake fase, when I typed ‘make’, see below:


:ppremake barbeirovsk$ make
make all-am
g++ -DHAVE_CONFIG_H -I. -DINSTALL_DIR=’"/usr/local/panda"’ -g -O2 -MT dSearchPath.o -MD -MP -MF .deps/dSearchPath.Tpo -c -o dSearchPath.o dSearchPath.cxx
filename.h:136: error: ‘vector_string’ has not been declared
filename.h:170: error: ‘vector_string’ has not been declared
make[1]: *** [dSearchPath.o] Error 1
make: *** [all] Error 2
c93418a7:ppremake barbeirovsk$


Some Idea what happened?


I remember when installing Panda in my linux, I had to compile from the source - I follow a Ubuntu tutorial for that -, and while it was beign compiled this message appeared a lot, but the whole installation was successful…

That’s really weird, since vector_string is defined by vector_string.h, which is included at line 20 of filename.h, not far above the line that generates the error.

So, no, not many ideas here. Are you sure your g++ environment is properly configured for compiling in general?


Hi David,

That’s a good question I do not know to answer. But I never did any configuration in the g++ compile, and honestly, I have no idea how to do it.

I did some college work with c++ using Xcode, and my Xcode is configured to compile using gcc. I never know if g++ and gcc are the same software or not, but anyway…