Maya

Is there a specific version of Maya I need if I want to be using this with Maya or can I just get the most recent version?

Any version will do - well, Maya 2013 is not supported in 1.8.0, but it will be available in the upcoming 1.8.1 version.

Oh, you do need the 32-bits version if you’re on Windows.