Maya Animations weirdness

Sorry about the topic name, but I’m not sure what to call this problem…

Basically, we tried exporting a model (a character) with animation into panda, and it works perfectly in Maya.

However, once we tried it in Panda, only one part of the model was animated (the head), the rest of the model remained static.

I think its because the head is detached from the body in the Maya file, but I’m not sure how to solve this problem.

Does anyone have any suggestions, or had this problem before?

Check your Hierarchy Editor to make sure both elements are parented correctly.

I don’t remember off the top of my head but I think every piece of the model needs to have a bone assigned, if that’s the case, then parent the static part to a root bone, then the attachment coming off of that bone.

from what ive experienced, in maya, the whole model has to be one mesh

the animation also has to have ALL the joints freeze-transformed in the model’s default position before any animation is done

by ALL joints it means the every joint needs to be individually freeze transformed, if you only select the parent joint and freeze transform, only the parent joint is freeze transformed, not the rest after it

the safest way to freeze transform joints is to unparent all joints, freeze transform all of them individually and re-parent them after the freeze transforms are done

if these 2 criterias are not fulfiled, the possibility of your maya animation screwing up is extremely high

if you’ve already solved the problem then nvm

Well… I’m not one to enjoy reviving new topics, but its another issue now with the same model…

We managed to solve the old problem already (I forgot to update the thread, sorry laperen…) but a new problem occured of a weirder variety.

The model’s arms now become stick thin during the animation.

In the maya file, the model’s arms are regular size, normal animation and all. But when exported to egg, the arms are suddenly… alot thinner, yet still attached to the model.

Did anyone ever have this before?

yes i have…or at least seen it happen to one fo my fellow classmates…

I wasnt really sure what was wrong myself, but when i asked him to do the steps i had done in my last reply…it worked fine

there are a few possibilities i could conclude though

  1. there may have been a few renegade joints that have not been solved

  2. the exporter might have screwed up for that moment exporting your model

3)maybe you have some parts of your model that are mirrored, try applying TwoSided(True) to see if that is the case

it may be other issues though