Maya 2015 and GeomNodes?


#1

I posted this in a topic of mine in Scripting Issues but I think it’d be more appropriate here.

This model is made and rigged from scratch, and I’m no Maya wizard.

It currently gives me this when I hit shift+L in pview :

ModelRoot eagle-heads.egg
    Character eagle-heads
      GeomNode  (1 geoms: S:(TextureAttrib))

but I need something along the lines of this:

ModelRoot duck-heads-250.egg
    Character duck-heads-250
      ModelNode DuckHead250Polys E:(CharacterJointEffect)
        GeomNode muzzle-short-neutral (1 geoms: S:(ColorAttrib TextureAttrib))
        GeomNode head-short (1 geoms: S:(CullFaceAttrib TextureAttrib))
        GeomNode head-front-short (1 geoms: S:(TextureAttrib))
        GeomNode eyes-short (1 geoms: S:(TextureAttrib TransparencyAttrib))
        GeomNode joint_pupilL_short (1 geoms: S:(TextureAttrib TransparencyAttrib))
        GeomNode joint_pupilR_short (1 geoms: S:(TextureAttrib TransparencyAttrib))

Does this simply mean I’ll have to create a new shape for every piece? Because I extracted faces from the original mesh into their own pieces, i.e.:




(the polygons are slightly different now, but still the same object. I deleted history to collapse each object into their own thing.)

Why doesn’t the model have a ModelNode, and how would I define these different objects?
Does this mean I would have to have multiple Maya files with each piece rigged to its own root, later compiled into one Maya file?

(If anyone would like, I can upload the most recent version of the .mb file so they could take a look.)


#2

I think you can force the egg loader to retain the individual GeomNodes by setting the type to “structured” in the .egg file (instead of “1”). I’m not quite sure whether it is possible to set this via the Maya exporter, but if not, you can set it manually in the .egg file using a text editor.

It is also possible to set egg-optchar to flag individual nodes not to be flattened, I believe.