Maya 2009

Is there any way to use Maya 2009 models and animations within Panda3D? There does not seem to be any support for Maya 2009.


For me to add maya 2009 support, someone would need to send me the devkit of 2009.

You could also try the 2008 exporter. If it doesn’t work, you’d need to compile Panda3D yourself (or send me the devkit)

I found this quote from you at … 687d3e8201

I’m guessing that this is no longer true and the CVS version no longer has support for Maya 2009?

The quote indicates only that Panda is capable of building a Maya 2009 exporter, provided you supply a Maya 2009 devkit. If you want to download Panda and built it yourself, you will have a maya2egg that supports your flavor of Maya, whatever it is.


After building Panda I tried the exporter and got error messages that the exporter can’t find the maya python packages. So I tried the tip to copy the
Then I add the Panda python directory to the PYTHONHOME variable. With that the most error messages where solved, but no egg file were created. Even with the opthion -ignore the converter crashes again. With verbose level 2 I get this:

Initializing Maya.
:maya(debug): Restored current directory to /c/My User directory
:maya(debug): Compiled with Maya library version 2009.0 (200900);
running with library version 2009.
:maya: Reading simple_cube2.mb
:maya(debug): cwd(read:before): C:\My User directory
:maya(debug): Restored current directory after ::read to /c/My User directory
simple_cube2.mb: (kFailure): Unexpected Internal Failure
:maya:mayaegg(error): Unable to read simple_cube2.mb
Errors in conversion.

Do I have to do more configuration work or do I have to config maya? I guess when somebody had checked in the maya2009 support, then this stuff has to work somewhere!


p.s. don’t be surprised that this is some kind of repost, but I had a problem with compiling Panda3D before

I wouldn’t copy the Maya Python libraries into your Panda Python distribution. That sounds like trouble, particularly since they might be using different versions of Python. You should keep them separate.

Instead, you should be careful to point your maya2egg at the proper version of Maya’s libraries before you begin. Maya2egg should try to do this automatically. The way it figures out how to do this differs according to whether you used ppremake or makepanda to build it.

If you used ppremake, it checks the setting of $MAYA_LOCATION. If you used makepanda, it checks the Windows registry.

Note that this only works for the command-line version of maya2egg. If you are trying to load a .mb file directly into a running version of Python, I think you will have difficulties because of the Python version conflict thing. The runtime load of Maya files no longer works since Maya 2008, when they went to Python internally.


OK, I delete the copy and try other ways. I add the path to panda.pth and to $PYTHONPATH, so that python still finds the maya libs, but I got the same error. Maybe it has something to do with DLLs directory from Mayas python version (probably 2.5.1) that differs from pandas. Well, I don’t know.

For further informations: I used makepanda to build the CVS version (building ppremake in cygwin didn’t work and I don’t know what to da with the exe after I build it with MS VS). The registry value for the Maya installation path is correct.

Googling a bit turns up that it doesn’t have to be a setup issue - try exporting a very simple thing, (like a cube) and see if that works.

As you can see in the error message my mb file is called simple_cube2.mb. I tried three different cubes. The standard cube with the the standard material, the cube with a phong material and the cube with a phong material and a texture. Every time the same error message.

Meanwhile I also try to convert the examples from Maya (in Maya2009\GettingStarted\Rendering), but that doesn’t work too. Has somebody else success with the maya2egg2009 exporter or are there still bugs in it?