maxegg.dle doesn't work

Hi, I’m trying to use Panda3d, it seems very interesting, but I can’t have the maxegg.dle exporter working.
I tried at work, I tried at home, I tried Max5, Max5.1, when I press the Done button, Max simply crashes.
I check the error log:

Error output piped to file. - (LOW LEVEL, SYS_ONE)
A new, piped logging instance has been created with data ‘MaxEggLog.txt’. - (MEDIUM LEVEL, SYS_ONE)
Set error mask for system with ID 5 to ff. - (LOW LEVEL, SYS_ONE)
Set error mask for system with ID 4 to 1f. - (LOW LEVEL, SYS_ONE)
Set error mask for system with ID 3 to ff. - (LOW LEVEL, SYS_ONE)
Set error mask for system with ID 1 to 7f. - (LOW LEVEL, SYS_ONE)
Set error mask for system with ID 2 to 7f. - (LOW LEVEL, SYS_ONE)
Set error mask for system with ID 0 to ff. - (LOW LEVEL, SYS_ONE)
#BEGIN {MaxEggPlugin::DoExport}
#BEGIN {MaxToEgg::Run}
finished building complete hierarchy - (MEDIUM LEVEL, SYS_FOUR)
Converting static model. - (MEDIUM LEVEL, SYS_FOUR)
Found a geometric object in the hierarchy! - (—HIGH LEVEL—, SYS_FOUR)
#END {MaxNodeEggGroup::ApplyTransformFromMaxNodeToEggGroup}
#BEGIN {MaxToEgg::Run}
TriObject attached and mesh generated! - (LOW LEVEL, SYS_FOUR)
Entered make_poly_set. - (MEDIUM LEVEL, SYS_FOUR)
Before obtaining transform. - (MEDIUM LEVEL, SYS_FOUR)
#END {MaxNodeEggGroup::ApplyTransformFromMaxNodeToEggGroup}
#BEGIN {MaxToEgg::Run}
After obtaining transform. - (MEDIUM LEVEL, SYS_FOUR)
Getting face. - (MEDIUM LEVEL, SYS_FOUR)
Before getting vertices. - (MEDIUM LEVEL, SYS_FOUR)
Getting vertex. - (MEDIUM LEVEL, SYS_FOUR)
After getting vertex pos before getting normal. - (MEDIUM LEVEL, SYS_FOUR)
After getting normal. - (MEDIUM LEVEL, SYS_FOUR)
after getting TVerts. - (MEDIUM LEVEL, SYS_FOUR)

Please, someone, help me! PLEAAAAASE, I really want to use Panda3D

hmm - Let us look into this, at some point we might have to ask for the model file that you are using for this.

Thank you!
I first tried to export a simple box without any textures and I also tried the max files in the resource library on the panda3d site, it always crash.


The .DLE doesn’t work for me either. No crashes, though. I can export a model from MAX 5.1 alright, but when I load it using

pview <ModelName>

it shows up without any texture or color (= totally white).

The .egg files from the panda library show up fine, when I do the same wih them - so the problem must be the exporter plugin.

Cheers, Fred.

I just wanted to let you all know that the current Panda team at CMU is working on improving the max exporters. In particular, we have solved two known bugs with it (polygon normal issues and exporting physiques) and are making an entirely new interface (using a .dlo helper object instead of the export menu).

The current version of the .dle I’m working on seems to work fine for Max 5,6, and 7, however, we have only used simple test cases to export and have not verified it on anything more “real-world.” So if you want feel free to send me models and the textures that go with them (the .max files and the output .eggs: a zip file that maintains your folder structure would be ideal) and I’ll take a look and see if the problem is with the exporter.

As for the models showing up white: When you make an egg, it puts the locations of the textures into the egg. For instance, if you save your egg into a folder named models, and you have a texture named “face.jpg” in a folder called textures, the egg will look for the texture in “…\textures\face.jpg”. If you move the egg to pview it and do not keep the textures in the same realtive path, then Panda won’t find them and they won’t show up. The way you can tell this is happening if if pview outputs lines like this in the dos window.

:gobj: Loading texture ../textures/face.jpg
:gobj(error): Texture::read() - couldn't read: ../textures/face.jpg

To fix it either make sure the texture is where it should be relative to the egg, or edit the egg file to point it to the right place.

There are some other reasons why textures wouldn’t display, and they all print errors in pview, so if you copy them here I may be able to help.

Ok - I’m still having problems with the exporter. What format does a texture have to be in, in order for Panda3d to use it - and are the textures automatically exported together with the mesh, or does the plugin only export the mesh? In other words: would the texture have to be exported using “render to texture” from inside 3dsmax, or are textures exported automatically together with the mesh?

It’s good to know that you guys are working on a plug-in for the newer versions of 3D-studio MAX - (as it seems that 3dMAX v.5 has some problems rendering to textures when run under Windows XP, Service Pack 2).

I’m trying to put together a game using panda3d, so being able to import my own (textured) models from 3dsmax would be just great…

Can anything be said about when the new maxegg-plugin will be available for download?

Thanks in advance, Fred.

Hi Fred,
An updated version of the .dle, including versions for Max 6 and Max 7 is part of the newest “experimental” release of Panda. The brand new .dlo exporter is in internal testing.

However, neither of these plugins have changed the way textures are handled. If I understand your question, textures are exported with the mesh. You should not need to do any rendering to get a texture.

In order to help you, I need you to answer some questions.
Open the exported egg file. It is just text can can be viewed in notepad (or wordpad if it’s a large egg).

Does the tag “” appear somewhere near the top of the file?
If it does, is your texture file actually in the directory listed on the next line?
What format is your texture? (jpg, tiff, bmp …)
Is your texture square and one of the following sizes: 16x16, 32x32, 64x64, 128x128, 256x256, 512x512, 1024x1024?
When you pview, watch the output in the dos window. What errors, that look like the one I listed in my previous post, are output?

I suspect that your problem is actually pretty simple. If you can answer those questions I bet we can narrow it down.

The exporter only exports the texture’s filename. So for example, if you apply “bobdole.jpg” to your model, then the egg file contains the string “bobdole.jpg”. It does not contain the pixel data.

Wow - the maxegg6.dle from the new experimental package works just fine. And thanks for the info on the texture handling, too.

On one of the models I exported from .max to .egg, there seems to be a problem with correctly rendering 2-sided textures applied to shapes. They show up transparent or with a default texture instead of with the one they’re assigned from inside max. Seems perhaps the “2-sided map”-property isn’t exported. Is there an easy workaround for this (- I can post the files if you would be interested in looking at them).

Also, rotation parameters for maps (setting the orientation that the map should have when it is applied to the faces) in max’s Material Editor, don’t seem to apply when they are exported to eggs. I had to rotate the map’s original JPG-image instead.

Minor issues, maybe already fixed in this new .dlo-exporter mentioned. Btw. when is this expected for release?

Anyway, just great to finally see some of my own models working in panda3d.


I ended up with white models also. When I checked the egg files I found that the models that turned up white, were exported without RGBA values in the polygon fields.

I thought about it and then made sure that before I exported said models I converted to mesh (you guys didn’t mention that, so that one might be overkill) and collapsed (which you did mention) them. This caused the models to show up pretty much the way they did in max(7).

Heads up FYI, is all.



I’ve checked my .egg file to make sure that the texture is mentioned, run PVIEW from the command line in the directory with both the texture and the model. I am using the MAX 7.0 egg exporter. It is a very simple piece of mesh - just a box really, with a 512x512 PNG texture applied. All I get is a white box. Any help would be greatly appreciated.

One other data point: when running PVIEW, I always get this error:

pview boxtest
Known pipe types:
(3 aux display modules not yet loaded.)
Loading boxtest
:display:gsg:glgsg(error): at 3420 of d:\temp\mkpr\panda3d-1.0.4\panda\src\glstuff\glGraphicsStateGuardian_src.cxx: invalid operation
608 frames in 10.652 seconds
57.0786 fps average (17.5197ms)


The problem was with my Nvidia drivers - I had older drivers and updated to the latest version (71.89). Fixed the problem right off the bat.