makepanda and other errors building from CVS

I just merged the latest from CVS into my repository (think I did a good merge, but everyone makes mistakes), and it seems there is a problem with makepanda.
It is referring to a variable “is_64”, but this is not actually defined anywhere.
I worked around this by just putting “is_64 = False” at the top, but there are other errors. (full output)
It is complaining about dSearchPath, but seeing as that hasn’t changed in almost 2 years I suspect it is related to the recent Filename changes.

is_64 is a new symbol I just added. It’s defined in It appears in both files in my view.

The compilation errors are a little stranger. It does seem like you might have a bad merge with your /, though; and perhaps this is related.


Ah, you are correct.
Looks like my cvs checkout actually keeps timing out on

That doesn’t sound good:
cvs checkout: Updating makepanda
cvs checkout: dying gasps from unexpected
Possibly there is some problem with the repository?

That sure does sound bad! But I’m able to access the repository just fine. Maybe some internet thing?


Looks like it was the compression option “-z3” specified during checkout. I guess there is something in that does not like to be compressed.
I still get these bizarre compile errors though.

Nevermind, it is building!
There were some files removed from the repository that I had allowed to continue to exist which, once removed, resolved my build issue.