Jump'n'Run game "Rising"

Hi everyone,

at the moment a few friends and me are working on a new modern jump and run game and searching for people willing to help us.

About the game:
The games name is Rising and it will be a modern jump and run game kind of like the Prince of Persia and Mirrors edge. The player has, at the very beginning, the choice of select one of two characters which will slightly influence the story and the characters abilities. The game itself will take place in a Hotel under construction, where the characters mission is to reach the top and do some things for its client on the way.

The Project is at a very early development state and is managed and hosted on Launchpad.net. So for anyone willing to help, just take a look at https://launchpad.net/rising.

I looked through your files and tried to run the main.py, but unfortunately we’re using different Panda3D versions and you used the bam format - so that I can’t load some of your models.

@Nemesis#13: I will set up an easy way to recreate the .bam files, so anyone can create them for their versions.

the new script to convert the eggs to bams and put them in the multifiles is ready now. Just update the code checkout from Launchpad or download it again. The script is located in the data_src directory and is named repack.py.
This script will call msgfmt (gettext), egg2bam and multify (both panda3d), so they should be installed. The script also has to be called from within the directory where it is located.
After the script runs through, the problems with the bam files should be solved.

Ok, now it starts, but then my screen switches the resolution to about 800x600 and the script stalls. I can still see my desktop and have to stop it with ctrl+c in the terminal.

the resolution of 800x600 is at the moment the default in the settings. You can switch from fullscreen to windowed mode with f11 this should change the resolution back to your default and just display the window in the given size.
About the other problem, this is new, could you give me maybe some more informations about that. There should be some log files in a directory named .Rising in your home folder. There is also a settings file where you could set, for example the screen resolution and enable/disable fullscreen.

After switching fullscreen to False all I get is a black window (without decoration) of 800x600px and my whole desktop freezes. I just had to switch to a tty and terminate my whole desktop environment (killing the python instance didn’t change anything!).




I’m running ubuntu precise with panda3d 1.8 from oneiric on a 64bit machine.
HW: laptop with dual core and onboard graphics of intel GMA 4500

Looks like there are some problems with setting the cursor file as of the line in the log file:
:display:x11display(error): BadCursor (invalid Cursor parameter)
Could you try commenting out or removing the two lines where the cursor is set.

props.setCursorFilename(os.path.join(settings.tmpPath, "cursor.ico"))

You will find them in
…/Developement/src/starter/SplashConfig.py in line 154
…/Developement/src/stateHandlers/StateFSMMain.py in line 60

Maybe your version of panda can’t set ico files as cursor. The OS should be able to handle this as I use Ubuntu precise too. Would you be able to somehow test with a more recent version of Panda3D, to check if it’s maybe another version problem? The current 1.9 development version should work.

The movie and audio errors in the log file could be ignored for now.

Just tried with most recent buildbot version and without the cursor change. The problem seems to be somewhere else.
The log file says:
:09-26-2012 14:18:52 :movies(error): Could not open sound/sfx/avatarWalk.ogg
:09-26-2012 14:18:52 :audio(error): Cannot open file: sound/sfx/avatarWalk.ogg
:09-26-2012 14:18:52 :audio(error): Could not open audio sound/sfx/avatarWalk.ogg
:display:x11display(error): BadMatch (invalid parameter attributes)

I think the last one is the most important.

the next thing you can try is set the ignorep3dhacks variable to False. You will find it in main.py in line 57. If it is set to False, most of the window properties are ignored and not changed.
If it still don’t work after that would you be able to debug the program to see where this problem comes from, as I have no idea what could cause this error.

It works with that option disabled.

ok, would be nice if you could find what has caused that error. The variable change mostly affects the SplashConfig.py in /src/starter/. The variable is checked in the init and in initMainWindowProperties function but your problem should be within the initMainWindowProperties.
Would be really great if you could find the problematic line and tell it to me.