Issues with resetPrevTransform using Panda3D 1.5.2

I developed a game awhile ago using Panda3D 1.1.0 and at the time it worked fine. I went to play it using the latest version of Panda and get an error “AttributeError: ‘libpanda.CollisionTraverser’ object has no attribute ‘resetPrevTransform’”. I checked the manual and added the line of code base.cTrav.setRespectPrevTransform(True) to my init function, but I still get the error. I comment out the code but it looks like the High Speed Collision detection stops working. Any suggestions?

Are you calling resetPrevTransform() explicitly? This is no longer a method on CollisionTraverser; it has been moved to PandaNode. But you shouldn’t need to call it explicitly in any case.

David

I see.

I removed the line of code, but it seemed like my high speed objects weren’t colliding. Do I then need to switch all my SetX,Y,Z functions to SetFluidX,Y,Z?

Yes, but that’s always been the case.

David

Thanks,

Now experiencing an issue with old Scalar Multiplication code.

Has the “int * Vec3” operation been removed?

There was never, to my knowledge, an operation that computed “int * Vec3”. Instead, we have “Vec3 * int”.

David