Issues with maya2egg85/2009

starting off with a .mb from maya, sending in the exporter using terminal (MAC) via bellow,

Terminal cmds:

/Developer/Tools/Panda3D/maya2egg85 -a model -o [output.egg] [exported.mb]

/Developer/Tools/Panda3D/maya2egg85 -a model -o wall_4.egg wall_4.mb

/Developer/Tools/Panda3D/maya2egg85 -a model -o Test.egg wall_4.mb

/Developer/Tools/Panda3D/maya2egg2009 -a model -o wall_4.egg wall_4.mb
/Developer/Tools/Panda3D/maya2egg2011 -a model -o wall_4.egg wall_4.mb

Both of which give the errors associated with the version of maya

version of maya being the error describing the “maya 85 versus the maya 85 service pack one”. these terminal commands worked flawlessly a month ago and starting last week, failed to complete.

eventually with the release of panda 1.7.2 i was able to get a .egg file with geometry information (via text editor/notepad) but using pview, the geometry was unviewable. however 1 out of 5 separate geometry exports worked, all of which have no difference in texture information animation or geometry information coming out of maya.

If any one could hep me out, it would be greatly appreciated.

Thank you in advanced.

I’m a little confused. Why are you running all of these different versions of maya2egg? You can only successfully run the version that corresponds to the version of Maya that you have installed locally. Which version is that?

When you say “the geometry was unviewable,” what do you mean exactly?

What do you mean by “texture information animation?” Texture parameters animated in Maya are generally not exportable to the egg file. Only animation of nodes and bones makes it through. You can also do limited animation of vertices via blend shapes, but you have to understand that system.


I ment that i’ve tried Maya 8.5 and then maya 8.5 with service pack 1, then maya 2009 and maya 2009 with service pack 1. to no avail.

I’ve used the maya2eggXX in hopes that one would work better. and at the moment maya2009 with maya2egg2009 works every 6th export or so. Every time in between exports but “pview” cannot view the geometry from maya. I hit “c” to center frame in pview and nothing shows.

Texture information being file attatchments or there being a file node associated with the phong shader.

previously i’ve been able to export without an issue to .egg and the geometry be viewable via pview. I’ve even been able to export a chan for blendshapes. but i’ve left my project alone for 2 months and now the exporter doesn’t work. or maybe its my pview that isnt working.

I use Maya 2011 to build my environment and textures, then export them as an fbx or obj. Then i would import them or open the .mb in maya 2009 and re-save my file so the exports are encoded with maya 2009.

Thank you for your reply by the way, this has been an issue to my team. :slight_smile:

OK, do you see error messages on the console when you view the model in pview? What is the console output if you press the “shift-L” key in pview? This should list the scene graph that pview loaded. If you have geometry, even if it is invisible for some reason, you should see some nodes listed.

For file textures, you should see a entry in the egg file. Do you see such a thing?

What error messages do you see, specifically, when you attempt to run maya2egg2009? Do you still have Maya 2009 installed on your machine? (Of course I wouldn’t expect it to work if you run maya2egg8.5, unless you have that ancient version of Maya installed on your machine as well, so don’t bother reporting the error messages from that.)


I’m not getting a Texture entry in the .egg file.

terminal printout:
PandaNode models
ModeLRoot Wall_2_Test.egg
Character Wall_2_2009
GeomNode (1 geoms: S:(ColorAttrib))

maya2egg2009 errors:
Errors in conversion.

Then the .egg file is created

maya vers installed:
maya 8.5
maya 2009
maya 2011

would having several versions effect the conversion process? I don’t understand how it could considering they are installed in their own directory. Maybe theres some pref file or workspace file that panda uses?

That list of nodes sure does look like you have some geometry. In particular, the bottom GeomNode is created only if you have some actual geometry there. Maybe it’s just invisible for some reason, for instance because the alpha is 0? If you press the “h” key it should draw a green wireframe sphere around the geometry.

Does it say anything before it says “Errors in conversion”?


Alright well in wireframe it seems that i do have an object in the pview but it isnt the object that i exported.

I take it that maybe pview is substituting the geometry from the egg file, that it aparently cant read, with a basic primitive that pview can?

the conversion goes through a cycle attempting to pull a png file that isnt associated with the shader that im using:
pandatoolbase(error)…[directory location]… png

By the way the Primitive is a sphere.

If there is any correlation to the issue.


pview won’t substitute geometry, but it does draw a wireframe sphere if you press the ‘h’ key. Is that what you’re seeing? If you just want to see your model itself in wireframe, press the ‘w’ key. Also try the ‘t’ key to disable textures in case your textures are causing problems.