Installtion Problem

Dear Sir;

I have read thru the tutorials, I dnlded the correct copy for windows (using XP) The greeting card works fine. I made the folder and saved it as advised with the .py extension.
I was able to open the python.exe (had to go to python folder and click the icon) or by clicking Start, run C:\Panda3D-1.3.2\bin\cgc.exe

Anyway… DirectStart does not work, and when running this script from manual:

import direct.directbase.DirectStart

#Load the first environment model
environ = loader.loadModel(“models/environment”)
#Run the tutorial

Nothing happens. I did exactly as the manual said and nothing. I can run the tutorials, each individually and they open in their own screens.

I am now at a total loss as I have not a clue what to do next. I did read through the this forum but did not see this particular problem addressed. Anyhelp would be greatly appreciated.

Can you be a bit more specific on ‘nothing?’

Are you seeing the main panda window open, but no model displayed inside? Or are you not seeing any windows open? If there are no windows open, what are you seeing on the shell console when you run the program?

We’ll see what we can do to help, once this is clarified.

Welcome to the community!

OK. When I open C:\Panda3D-1.3.2\bin\cgc.exe A small python window does open. But when I type that script in as stated in previous post, absolutly nothing happens. No other window opens.

I am not getting the Panda Screen at all.

Why are you opening cgc? That’s the Cg compiler. You sure you had a proper look at the tutorials?
You have to use ppython to run Panda scripts

Beacause I was trying everything Sir!

This is what happened:
From the C:\Panda3d-1.2.3\python\ppython.exe

At command prompt: “ppython” Without the quotation marks ( is the name I assigned this text file).

This is the error message I get:

File “<stdin”>, line 1

SyntaxError: invalid syntax

I thought that IF the manual is correct (and I assume it is) then I must be opening the wrong .exe in which to type the Command to get the panda window started. So I indeed tried all .exe files I could find getting all the same results i.e., a syntax error or no response at all.

Any help would be greatly appreciated.

That’s strange, I just copied your code into a file, and ran ppython with it and it worked with no such problems.

Wait, did you run ppython.exe and then type in ppython Cause what you did then was enter the interactive Python console, and that of course is not valid Python code.

What you have to do, is go into a DOS command prompt, go to the directory where is, and type “ppython”, or alternatively “C:\Panda3D-1.3.2\python\ppython.exe”. Those two should be equivalent if you have a normal Panda installation.

Perhaps you should read some Python tutorials before you continue with Panda, because if you had some basic notions of Python this would’ve been obvious.

Perhaps you should read some Python tutorials before you continue with Panda, because if you had some basic notions of Python this would’ve been obvious.


Perhaps “I have read all the tutorials, and tried everything” (all resulting in sytax errors or no response at all) was not clear enough for you to understand the problem.

The 1st thing I did in all this was do exactly that (C:\Panda-1.3.2\python\ppython.exe pstart

And I recieved an error message as follows: C:\python\ppython.exe: can’t open file '" : (Errno 21) No such file or directory

From there I made sure the file was in the python folder (it is and was), I then tried ALL OTHER .exe files just to see if perhaps the DOS was not where it was supposed to go.

I am truly sorry I have been a bother to your MOST EXCELLENT KNOWLEDGE OF PANDA, but your rudeness, abubtness, and assumptions of MY lack of knowledge has been of absolutely NO help!

Perhaps this forum is not where 1 should seek the help needed to get the Panda to run, as it is obvious from your posts that it is nothing but a bother to you!

IF this post is deleted due to honesty and seeking NON-CRITICAL help, then so be it.

For anyone else having this same problem… (i.e., Wont read your file made per Manual instructions)

From DOS Prompt type: C:\Panda3d-1.3.2\python\ppython.exe
then when the at the next prompt ( >>> ) type in directly

import direct.directbase.DirectStart

That will start the window, even when python is not reading the created file.

Patience, Kaujoi. psiberpunk’s “assumptions” about your lack of knowledge are based solely on your posted error messages. Don’t be angry with psiberpunk just because you were not clear in your questions.

The error message:

is a Python error, not a DOS error. It means something is either wrong with your script, or what you typed into the python interactive interpreter (the prompt looks like this >>>) is invalid. So debug it. If you can.

Sorry if I offended you. I meant to say that if you had experience running normal Python scripts you could just apply the same knowledge to running Panda scripts.

I think it’s a bit unfair to say I’ve been of no help, I took the time to run your script and tell you why you were getting that error message. Anyway…
I’ll go step by step on what I think would be a sure-fire way to get a script to work.

  1. Open a command prompt via the start menu. Type 'cd '. If you’re in Windows XP you can use the tab key to fill in the directory name based on the first few characters you type. For instance if you type ‘cd c:\pan’ and then press tab you should probably get ‘cd c:\Panda3D-1.3.2’ unless you have other directories that begin with ‘pan’.

  2. Once you see are in the proper directory (you can type ‘dir’ to confirm that your file is in this directory), type 'ppython ’ note that the name should include the .py extension.

The first thing you should see is this:

DirectStart: Starting the game.
Warning: DirectNotify: category 'Interval' already exists
Known pipe types:
(3 aux display modules not yet loaded.)

and then the window should pop up.

Pity if you’ve left this place, you’ve missed the whole party. :smiley:
Just to save your time, you can try this :

  1. open the Folder Options. (in Control Panel, or Tool>Folder Options in win explorer)
  2. bring up the File Types tab.
  3. select “Folder” type and click Advanced. Be very careful, don’t mess up with “File Folder” type, it can ruin the actions priority, and you’ll have to fix it only by editing the registry !
  4. create new action, you can name it “PROMPT to here !” or something similar.
  5. click Browse, and select the “cmd.exe” in \WINDOWS\system32 as the application used to perform action.
  6. confirm everything.

Using it :
If you right-click any folder, you should see “PROMPT to here !” on the menu. Click it to open the command prompt and directly bring you to that location, as fast as you blink. Then you can start ppython, make sure to INCLUDE the .py extension.

Have funnn !!