Installing wxPython beside Panda3d


I’ve tried to install wxPython but somehow I just didn’t get it configured properly. To begin with:
I’m using windows 7 64bit

I wanted to try the default leveleditor from the direct subfolder of the panda3d directory and started it from the console with ppython. However I got the error message that there was no wxPython installed. Therefore I downloaded wxPython and ran the installer. It detected my standard python 2.7 in the registry (note: I also have panda in the registry) and suggested I should install it into the lib/sitepackages folder of the standard python. I did what the installer wanted but still got the error. So I ran the installer again and this time installed wxPython into the python/lib/sitepackages folder of panda3d. I didn’t set that installation to be the default wxPython because I imagined that other applications might need it, too and they certainly wouldn’t look into the panda3d version. Maybe that was wrong because I still can’t run the editor.

This is my output for

ImportError: No module named wx

it’s the same for python

What can I do?
Thank you for your time

Is there any wx.pth in site-packages ?
If there isn’t, just copy the one from py2.7’s site-packages.

That worked well. There’s no complaint about missing wxPython anymore. However I get this error:

ImportError: DLL load failed: %1 is no appropriate Win32-Program

Pleas note that this is a translated version. I’m german and “appropriate” was the best match for “zulässig” that I could think of.

By the way. What exactly did wx.pth do?

Could be mismatched python version.
P3D 1.7 uses py2.6, so you should install wx for python2.6.
Any file with .pth extension holds the path to the package’s installation, so python can find it.

I tried the python 2.6 version. It still terminates with the same error.

Could you post the full stack trace ?

This is all the output:


Is your wxpython 64bit ?
Panda’s python (32bit) won’t be able to load 64bit libs.

That finally did it.
Thank you very much