Installation on Fedora 6...

After reviewing some of the other postings about the Config.prc location, I felt certain that was my problem. First, the compiliation went well, after a brief hiccup over osmesa.h and finding an rpm. This is a non-standard build and install for my Linux desktop. When running a project from samples/ I get the following:

>> ppython
DirectStart: Starting the game.
Warning: unable to auto-locate config files in directory named by "<auto>etc".
Warning: DirectNotify: category 'Interval' already exists
Known pipe types:
(all display modules loaded.)
Traceback (most recent call last):
  File "", line 1, in ?
    import direct.directbase.DirectStart
  File ".../panda3d-1.3.2/built/direct/../../direct/src/directbase/", line 4, in ?
  File ".../panda3d-1.3.2/built/direct/../../direct/src/showbase/", line 195, in __init__
  File ".../panda3d-1.3.2/built/direct/../../direct/src/showbase/", line 545, in openDefaultWindow
  File ".../panda3d-1.3.2/built/direct/../../direct/src/showbase/", line 606, in openMainWindow
    self.openWindow(*args, **kw)
  File ".../panda3d-1.3.2/built/direct/../../direct/src/showbase/", line 434, in openWindow
  File ".../panda3d-1.3.2/built/direct/../../direct/src/showbase/", line 377, in makeDefaultPipe
  File ".../panda3d-1.3.2/built/direct/../../direct/src/directnotify/", line 122, in error
    raise exception(errorString)
StandardError: No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

The Config.prc is in …/built/etc and I set the $PRC_DIR appropriately. There is an entry

in the Config.prc file.

When I run pview, I get a window with the accompanying message:

I assume that this is still a problem with locating Config.prc, but I don’t understand why my initial setting is not working? Thanks for any help.


try to set the $PRC_DIR environment variable to the path where the config.prc is located.

There is a file created in …/built/etc/Config.prc, when compiled. I did set the env var $PRC_DIR to the path …/built/etc/. Same results concerning the pipe types.


Ehm. I see you have left everything in the /built/ dir, its more recommended to do something like this:
the contents of built/bin to /usr/bin
the contents of built/lib to /usr/lib
the contents of built/etc to /etc/
the contents of built/include to /usr/include/panda3d
and, ehrm. put the rest in /usr/share/panda3d
(if i didnt forget anything)
That works just fine for me.

seems as if the install script didn’t went through?

Just a guess, through… :frowning:

Regards, Bigfoot29

By the way. Panda3D has an RPM for Fedora 6! Why dont you try that? You can find it at the Software Downloads here at

Thanks, bigfoot29 and pro-rsoft, for the info. It verifies what I have felt about the process. I did not watch or collect all the output of the compilation; it might have terminated prematurely.

There is a slight complication. I am installing Panda on a desktop to run as a server, but I do not have admin status. I thought I would attempt to compile in $HOME and run from there. Not something I typically like to do, but I thought I would give it a try. But, I am going to ask our systems guys to use the rpm to install it in all the default locations.

Thanks, again.


We installed the rpm for Fedora 6 and the test projects in /samples are working fine. Now onto running client-servers.


I tried compiling panda myself once as non-root and the building was not completed. Only when I build it as root would the build process be completed. This was on FC5.
I don’t know if it is possible to indicate that panda should be installed in a different location than /usr/…