install problems

Dear All,

I’m trying to install panda3D on my Ubuntu 13.10 laptop (64bit). I don’t have nvidia graphics (I have intel integrated) so none of the .deb files seem to be right.

So I grabbed the source from this site for version 1.8.1 and compiled using the makepanda system: --nothing --use-python --use-ode --installer

This built a .deb file. I installed the dependencies that I could work out and installed the .deb using:

dpkg -i panda3d1.8

This worked fine (after installing some more dependencies).

However, I can’t run the example files… The error message is:

DirectStart: Starting the game.
Traceback (most recent call last):
  File "", line 13, in <module>
    import direct.directbase.DirectStart
  File "/usr/share/panda3d/direct/directbase/", line 3, in <module>
    from direct.showbase import ShowBase
  File "/usr/share/panda3d/direct/showbase/", line 14, in <module>
    __builtin__.config = getConfigShowbase()
NameError: name 'getConfigShowbase' is not defined

Can anyone help?

Thank you,


By adding --nothing, you compiled without support for almost all Panda features, including the “direct” modules, which you need for running most of the Python samples. That’s why you’re getting this error. I suggest building with --everything instead.

Keep in mind that none of the distributed .deb’s actually require nvidia. They do require nvidia-cg-toolkit, which you need to use shaders regardless of whether or not you have an nvidia card.

Hi rdb,

Thank you for the fast response. That worked perfectly apart from needing to disable bullet due to an error during compile (the option to do so isn’t in the INSTALL-MK file yet but to be fair that file does say that it may not be up-to-date and it was in the --help output).

Thank you again,