ImportError: /usr/lib/panda3d/libp3dtoolconfig.so: undefined

Hello,

I was using an old version of panda3D wich was working, and instaled panda 1.5. The instalation seemed to work, but then when I tried running panda, an import error occured.

Here is the traceback of the error when I try an import from pandac.PandaModules on python2.5:

from pandac.PandaModules import *
Traceback (most recent call last):
File “”, line 1, in
File “/usr/share/panda3d/pandac/PandaModules.py”, line 1, in
from libpandaexpressModules import *
File “/usr/share/panda3d/pandac/libpandaexpressModules.py”, line 1, in
from extension_native_helpers import *
File “/usr/share/panda3d/pandac/extension_native_helpers.py”, line 38, in
from libpandaexpress import *
ImportError: /usr/lib/panda3d/libp3dtoolconfig.so: undefined symbol: EVP_CIPHER_iv_length

Any idea about what the issue may be?

This seems like a conflict with the OpenSSL library version. I’ll bet you have multiple versions of libssl.dylib on your system, and you’re getting the wrong one.

David

i have the same problem…

anyone could fix it?