ImportError: No module named panda3d.core

Hey guys,

I’m trying to go through the “hello world” tutorial on this site and I’ve hit a snag. I typed in the code for this part; [link]http://www.panda3d.org/manual/index.php/Using_Intervals_to_move_the_Panda[/link] and got the following error:

Awesome. I’ve Googled the error and tried adding the installation directory for panda3d to my python installation “C:\Python31\Lib\site-packages”, then I modified my PATH variable to have access to my installation of python, panda3d’s python, panda3d’s directory AND panda3d’s /bin file.

EDIT: I just tried removing the /bin and panda3d’s python directories from the PATH variable and still had the same problem.

Any ideas?

You shouldn’t attempt to use Python 3.1 with Panda3D. The downloadable distribution is compiled against Python 2.6, and it won’t work with any other version.

I just installed Python 2.6, re-installed Panda3D, and got the same error. Ideas?

Found the solution: I needed to use

from pandac.PandaModules import Point3

instead of what was given. Apparently the line in the tutorial is for panda3d version 1.7