ImportError: No module named direct.gui.DirectGUI

I just installed the RPM onto Fedora Core 3, and ran some of the tutorials. Most I’ve tried worked so far, except the chessboard tutorial. It gives me:

[mike@pc-00069 Feature-Tutorials–Picking]$ python
DirectStart: Starting the game.
enumerate is already present in builtin
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(all display modules loaded.)
:audio(error): Fmod initialization failure.
:audio(error): Fmod initialization failure.
Traceback (most recent call last):
File “”, line 13, in ?
from direct.gui.DirectGUI import *
File “/usr/lib/python2.3/”, line 399, in import_module
m = self.load_tail(q, tail)
File “/usr/lib/python2.3/”, line 452, in load_tail
raise ImportError, "No module named " + mname
ImportError: No module named direct.gui.DirectGUI

Did I forget to do something?


Nope, looks like a genuine bug, that wasn’t detected on Windows.

The name of the module is actually direct.gui.DirectGui–the case appears to be incorrect in the tutorial. In Windows’ case-insensitive filesystem, the program runs anyway, and the incorrect case goes unnoticed.

We’ll make sure the problem is fixed here; in the meantime, you can run the tutorial by editing the file and correcting the error.


Oops, didn’t really check those on Linux. I’ll have it corrected for the next update. Feel free to report any more problems you find.

Oops! :slight_smile:

I’ll try, but my hard disk decided to play up again last night, so I’m not sure if I’ll be able to stick to using Linux. I may have to switch back to Windows.

Anyway, thanks for the replies.