ImportError: No module named direct.directbase.DirectStart

Ehh… how did i manage to get this error?
I must have installed it wrong or…?
Cuse im using netbeans IDE, but that shouldnt make any diffrence…
Do you know whats wrong?
(And yes, now i can script in python)

It means netbeans can’t find panda’s modules. Have you installed a separate version of Python besides the one that Panda installs? You’d need to configure Netbeans to use Panda’s copy.

Ahh, ok…
How do i do that?

I dunno. That’s specific to the IDE you’re using, consult its documentation.

PS. This is part of the reason why IDE’s are not recommended for beginners.

oh ok, but if i run them in command promt then it still wont run the right python right?
It will run my real python and not the panda3d right?

Depends. If you use ppython instead of python, you make sure you’re running Panda’s copy.

but im running python 2.6.1 and iv never heard of a Ppython…
But on common python (^) then how do i change it to run pandas python?

Ok, now iv manage to change the python exe to run to the python.exe inside the python folder inside the pande folder…
But still it doesnt work… why?

Now iv tried using both python and ppython and none of them worked…

In windows: Panda has been compiled with python 2.5, and on windows panda will install its own version of python 2.5. If you installed panda to be set up alongside your existing python installs ppython will automatically be available.

In Linux: Panda is installed under python 2.5. Linux distros are now moving to 2.6 as the default, such as mine. I cheated by creating a symbolic link in /usr/bin called ppython and linked it to /usr/bin/python2.5

I’ve been trying to compile using 2.6 with makepanda, but I am obviously missing something as the deb installed renders panda unusuable under 2.5 or 2.6 =p

Which distro are you using, croxis?

Well i will never get this working so il be learning using blenders game engine…
Does panda have something blenders game engine doesnt have?
Cuse they both script in python…

I’m using ubuntu jaunty (to be 9.04) 64