import 3d studio max texture

I’ve followed the tutorial and I’ve importeted a model with animation on panda 3d from 3d studio max 7 but I can’t see the textures…
How can I import them into the eggs?

Do you know if it’s possible to import and work with normal map/bump too?


I don’t think there’s anything special to import a model with textures; they should come in by default. I suppose there might be a problem locating your textures. Are there any error messages about the texture files when you load the egg file?

There’s not presently any way to import normal/bump maps directly from Max (or any package). You’ll have to reapply them using Python code, by defining an appropriate shader, once the models are loaded. This is because normal maps are not part of the standard fixed-function rendering pipeline on your graphics card, and generally have to be specially coded with a Cg shader.


I know that import a model and his texture should be by default but anyway it doesn’t work…
I’ve not error messages but I can’t import the textures of the model, just the model and his animation…

If you examine the egg file after you have exported from Max, does it mention the textures? You should see them listed near the top of the file, something like:

snarf {

Are the textures listed there, and is the path correct?

Also, now that I think about it, what format are the textures stored in? Panda understands png, tiff, jpg, bmp, and a handful of less common formats, but not things like gif.


thanx for your answer but even if I followed all of your instrutions my model still doesn’t have a texture :frowning:
I’ve seen that in the egg file there’s nothing about texture so I tried to edit it by myself and use a texture in png format in the same folder but nothing…it still without texture.

Really don’t know what to do…I feel sorry 'cause I like panda 3d but even if I follow the manual…nothing :frowning:

can u help me?

Right, I was trying to help you diagnose the problem. We haven’t started trying to solve it yet. Knowing that there are no entries in the egg file tells me that it’s not a problem with Panda, per se, but rather a problem with the 3DSMax Panda exporter.

Unfortunately, you can’t just add entries to the top of your egg file and expect it to work. The polygons in the egg file will need to have references to the textures as well. We’ll have to figure out what’s wrong with the exporter.

Is there something unusual in the way the textures are applied to the model in your Max scene? Maybe the exporter is simply unable to find your textures.


I’ve tried differet kinds of textures but nothing…I’ve cheked the textures format and I tried with bmp, jpg and png…but nothig…the model and animation is great but no textures… :confused:

hey…you are very kind and thanx for your help…I was a litle bit depressed :confused:
feel free to contact me by icq…n. 281847344

I forgot to tell you than I use the panda 3d 1.0.5 version…

Hmm, unfortunately, I may be reaching the end of my ability to help. I know next to nothing about the Max Panda3D exporter, I had nothing to do with its development, and I don’t even own a copy of Max. I don’t know why it doesn’t appear to be converting your textures, but I do know that other people have used it successfully.

Maybe someone else on these forums who has had experience with using the Max exporter can lend some advice?