I can't use NodePaths

Hey all,

I’ve successfully created my own Panda3D game using C++… well… i have one problem now.
whenever I make use of NodePath it compiles well, but when I run it i get the following error:

./ppview: symbol lookup error: ./ppview: undefined symbol: _ZN17NodePathComponent5CData12_type_handleE

This is my code:

#include "pandaFramework.h"
#include "pandaSystem.h"

PandaFramework framework;

main(int argc, char *argv[]) {
  framework.open_framework(argc, argv);
  framework.set_window_title("A Panda3D Hello World");
  WindowFramework *window = framework.open_window();    
  NodePath myNodePath;
  framework.main_loop(); //equal to run() in python
  return (0);

If I leave away the line where the nodepath is created, it works.

Anyone knows what the problem is?
I tried everything.

Any ideas are welcome.

It’s pretty mystifying. But I think I just figured it out.

The symbol “_ZN17NodePathComponent5CData12_type_handleE” exists in the CVS version of Panda. But it was only recently added, and it didn’t exist in version 1.3.2 of Panda.

I bet you’ve got 1.3.2 installed on your disk, and you’re inadvertently pulling in the libpanda.dll from that version, instead of the libpanda.dll that you built when you built your custom version of Panda from CVS.

Make sure you’ve uninstalled all other versions of Panda, and try again.


David, you made it work! Thank you thank you thank you!!!

I had the old one still installed.