Help please?

I keep on getting this error verytime i try to run a simple script in python… im on OSX Yosemite.

and heres the error log… -_-

:slight_smile: thanks

Do you have an official 1.9.0 build from the download page?

How do i check the version?

Well, you can check it by importing one of the Panda3D modules, but that’s precisely what you are unable to do here. I’d suggest downloading the 1.9.0 release from the download page and installing it just to be sure.

The Developer one?

ok, i installed it and i get this now…

Has anybody gotten Panda3D to run on Yosemite? I’ve been at this for a couple days now, can’t load the modules… I’m beginning to think it’s an issue with OSX 10.10, unless somebody can say that it works for them.

I’m getting the same error… tried installing all the different panda3d version, using Python 2.7 on OS X Yosemite.

Which version of Panda3D did you install? You need this one: … SX10.7.dmg

It may simply be the case that you have more than one version of Python on your system. Try explicitly running “python2.7”. If that doesn’t work, try /usr/bin/python2.7 .

Have you tried running it using ppython instead of python I’m on Yosemite, and can only run Panda3D using the terminal command ‘ppython’ (it will not run in pycharm or IDLE), it will run Python using the version that Panda3D requires.