Help! Installation problems!


#21

You’re missing the OpenGL developer files. You’ll need GL and GLU. I think that on fedora, the package name is something along the lines of libmesagl and libmesaglu. I could be wrong about that. Of course, you could also search for gl.h and glu.h.

I warned you that you were only 5% of the way there! :slight_smile: But I think you’re closer to 70% now, so you’ve made a lot of progress.

As for a complete list, I’m afraid not. Yesterday, when you asked about libpng/libjpeg/libtiff, I tried to see if there was anything else you were missing. I couldn’t find anything - but apparently, I forgot that libGL and libGLU might not be standard under linux. I’m sure there are other things that I’m forgetting.


#22

Youpee! Succesfully built! :smiley:
I have to go right now, but tomorrow I’ll test it and send the RPMS to you, Josh.
Thanks for all your help!


#23

It installed fine, but when I run GreetingCard with ppython, I get an error:

Traceback (most recent call last):
  File "GreetingCard.py", line 1, in ?
    import direct.directbase.DirectStart
ImportError: No module named direct.directbase.DirectStart

The panda3d lib and bin directories are in my PATH and ld.so.conf…


#24

My hunch is that you might have missed an important piece of documentation. If you look in the “doc” directory under “INSTALL-MK”, it tells you how to install panda. There are some steps in there that you probably missed.


#25

OK, I rebuilt Panda3d… same error.
Now, I added the /usr/local/panda3d, /usr/local/panda3d/lib, /usr/local/panda3d/bin (just to be sure) to the $PYTHONPATH env var.
But this is what I get now:

[root@localhost panda3d-1.3.2]# echo $PYTHONPATH

[root@localhost panda3d-1.3.2]# export PYTHONPATH=$PYTHONPATH:/usr/local/panda3d
[root@localhost panda3d-1.3.2]# export PYTHONPATH=$PYTHONPATH:/usr/local/panda3d/lib
[root@localhost panda3d-1.3.2]# export PYTHONPATH=$PYTHONPATH:/usr/local/panda3d/bin
[root@localhost panda3d-1.3.2]# ppython /usr/local/panda3d/samples/GreetingCard/GreetingCard.py
DirectStart: Starting the game.
Traceback (most recent call last):
  File "/usr/local/panda3d/samples/GreetingCard/GreetingCard.py", line 1, in ?
    import direct.directbase.DirectStart
  File "/usr/local/panda3d/direct/src/directbase/DirectStart.py", line 3, in ?
    from direct.showbase import ShowBase
  File "/usr/local/panda3d/direct/src/showbase/ShowBase.py", line 10, in ?
    from pandac.PandaModules import *
  File "/usr/local/panda3d/pandac/PandaModules.py", line 1, in ?
    from libpandaexpressModules import *
  File "/usr/local/panda3d/pandac/libpandaexpressModules.py", line 1, in ?
    from extension_native_helpers import *
  File "/usr/local/panda3d/pandac/extension_native_helpers.py", line 20, in ?
    from libpandaexpress import *
ImportError: /usr/local/panda3d/lib/libpandaexpress.so: undefined symbol: panda_version_1_3_0

#27

OK, I’ve made some progress.
I thought the LD_LIBRARY_PATH is the same as PATH…
I checked the LD_LIBRARY_PATH and it was empty!
So, I added the panda3d and bin and lib folders to the PYTHONPATH, PATH, and the LD_LIBRARY_PATH, and now I got this error:

bash-3.1$ ppython /usr/local/panda3d/samples/GreetingCard/GreetingCard.py
DirectStart: Starting the game.
Warning: DirectNotify: category 'Interval' already exists
Known pipe types:
  glxGraphicsPipe
(all display modules loaded.)
:display:glxdisplay(error): OpenGL GLX extension not supported on display ":0".
:12-12-2006 16:37:54 ShowBase(warning): Unable to open 'onscreen' window.
Traceback (most recent call last):
  File "/usr/local/panda3d/samples/GreetingCard/GreetingCard.py", line 1, in ?
    import direct.directbase.DirectStart
  File "/usr/local/panda3d/direct/src/directbase/DirectStart.py", line 4, in ?
    ShowBase.ShowBase()
  File "/usr/local/panda3d/direct/src/showbase/ShowBase.py", line 195, in __init__
    self.openDefaultWindow()
  File "/usr/local/panda3d/direct/src/showbase/ShowBase.py", line 572, in openDefaultWindow
    raise StandardError, 'Could not open window.'
StandardError: Could not open window.

Which means: there’s a problem with my NVIDIA X driver… (even the xorg log admits it…)
I’ll see if there are any updates on the NVIDIA website… :slight_smile:


#28

:smiley: Youpee! it WORKS!!
Downloaded a newer kernel version, newest NVIDIA drivers… and panda3d works now :slight_smile: Thanks for all you help!
And Josh, if you still want to build a Mandriva rpm, click HERE to download the necessary RPMS.
If I forgot to include one, you can download them HERE, just click Advanced search, check Mandriva, check New Look For FTP Search etc…


#29

Josh, still up to build a Mandriva rpm?