Hardware Acceleration error

First of all, yes, my computer is an ancient piece of crap. All I have is the most basic integrated video card, but I’ve gotten panda to work just fine before. But when I attempt to run snaptothegrid’s Retro Terrain system, I get this error.

I’ve tried going into the Config file and putting a # in front of the “framebuffer-hardware #t” line, but I get the same error. Also, I have it set to use DirectX9 not OpenGL, so why would it give me an error in reference to OpenGL? Anybody know what’s wrong?

It sounds like you’re not editing the Config.prc file that it’s actually reading. Whatever Config.prc file it is reading is clearly requesting OpenGL, not DirectX; and it still has the framebuffer-hardware line.

Note that the better way to avoid this error message is to download an updated graphics driver from your graphics card manufacturer.


It’s the Config file in the folder “etc”, correct? If not, how do I find it?

Also, I’ve tried that but this computer is about 8 years old, and it already has the most updated version of it’s graphic drivers. It’s just a piece of crap, but I have no way of getting anything better right now. No money.

You can prove which file is loaded with a Python program:

from pandac.PandaModules import ConfigPageManager
print ConfigPageManager.getGlobalPtr()


Alright, I got it to work. Apparently in the program, he was forcing it to use OpenGL instead of DX9. I changed that and it worked. Thanks for your help in any case. :slight_smile: