Geometrical MipMapping terrains causes lag

i am making a test terrain which is just a flat plane.
here is how i make it:

       self.terrain = GeoMipTerrain("terrain")

But whenever the camera has the terrain in veiw it lowers the framerate a ton. is there somethign i can do to fix this. because if i “hand make” the terrain in blender even if its fairly detailed … it never did this so i dont know how im getting this immense framerate drop .

I have an ATI graphics card that isnt supported in fglrx so i had to use the open source driver but i havent had this problem before and the game ran just fine?

It works just fine for every one else. Maybe you are setting insane sizes? Does brute force off change any thing?

Your next step would be Pstats.

Hm, setting the min-level and block-size would be your best bet, in your case. Or, disable bruteforce and go for LOD.

Even with bruteforce, blocksizes are important.

You have to fiddle with the Near/Far, blocksize and min-level parameters. I used Pstats and turned on wireframe rendering to get an idea of how many triangles I was getting out of my geomipterrain, adjusting until I had values that worked well.

It’s a balance between blocksize and detail level. Larger block sizes mean less chunks that can be visibility culled, and can require a lot of time to rebuild if your camera is moving around a lot. But smaller blocks require more shuffling for the LOD generator and raise the geom count, so it’s a trick finding an acceptable compromise.

thanks guys i set the terrain chunk sizes bigger andnow i have no lag and it dosent take more than a millisecond to load :laughing:

Interesting, I’d make a notice about that in the manual.

(When I’ll have time)