from panda3d.core import Point3 Problem

Ok, so I searched for a bit on the forum and google, and it seems that no one (that I know of) has had this problem. (at least specifically)

I’m trying to learn this by following the manual but I get to a part where it says to type

from panda3d.core import Point3

and I am using Panda3d ver1.7
(at … _the_Panda)

But when I try to run the code (and since I need Point3 for alot of things! it’s important!) it errors out and says

ImportError: No Module named panda3d

How do I fix this?
And I ran an older version of panda3d and don’t remember having this problem (I’m refreshing by running through the manual again…)

Thanks for any and all help!

Hmm… well, older versions of Panda3D didn’t have the panda3d namespace, so if you ran through it before, then you probably imported pandac.PandaModules.Point3. Though, if you’re using Panda3D 1.7, then I haven’t a clue as to why it wouldn’t recognise the panda3d namespace. You’re sure you’re using Panda3D 1.7? Also, what happens if you replace that line with this one?

from pandac.PandaModules import Point3

Well, I guess I “think” I’m running 1.7 for the reason that I have an earlier version on my computer that I was working with awhile back, but since I’m jumping back into it I decided to install the newest sdk. So since I installed the newest sdk I assumed that it would replace the old paths (at least I hoped it would). So that when I ran the code python would automatically use 1.7

Yeah your code you suggested worked, thanks your a life saver.

What can i type into command prompt to show what version of panda3d that python is trying to use?

from pandac.PandaModules import PandaSystem
print PandaSystem.getVersionString()

Oh jeez, I thought when I used the installer it would update everything. Is there something that can show me how to change which version python uses?

Thanks again guys, you are a lot of help! I’m glad I joined this forum!

Normally, you choose which version of Python you’re running based on the particular python.exe that you run to get things started. If you just type “python” or “ppython”, then it depends on which one is first on your PATH variable, so you can edit your PATH variable to put the one you want first.

But if you want to be sure you’re not using an old version of Panda, the easiest way is just to uninstall all the versions except the one you actually want to use.


Yeah ok, thanks!

I switched the order around in the path and that fixed it. But then i just decided that I might as well get rid of it if I’m never going to use it again (that I know of haha)

Thanks for the great help. I think everything is solved here!

I have only just started with Panda3D and I am also going through the tutorial in the documentation.

The command in the tutorial appears to be incorrect.

from panda3d.core import Point3

As noted here, changing the command to:

from pandac.PandaModules import Point3

fixes the problem!

I only have one version installed: Panda3D V1.6.2

for panda 1.7.0 the import panda3d.core lines are the new and recommendet way of importing. keeping the manual up to date with the latest version of panda sorta makes it hard to include the old names,too.

if you are still using 1.6.x releasese you can have a look at the old api doc which still contains all the “old” import lines:

Since I am new to Panda3D, please tell me which is the newer line of code… and does that mean when I upgrade to 1.7, will I then have to change lines of code, or are they backwards compatable?

The panda3d.core line is newer, and will only work with Panda3D 1.7.x and above. The pandac.PandaModules line is the old way, but it will still work in 1.7.x.

Thank you!


Making my presentation at work at Sunday for tomorrow and when moving the files to notebook this came up.

Very big thank you.