freeze particle effect

are there any solution to freeze particle effect ? For example if I press some key board, it would freeze the particle effect.


Whats about an event, that removes it from the render tree?

wouldn’t that make the particles dissaper instead of “freezing” in midair?

From what I can see, there isn’t a function to do that.


There’s been a fairly recent change to the way particle intervals work. We haven’t updated the manual to reflect the changes yet, so I’ll do my best here for the moment. I have noticed that the API reference has been updated, though, so maybe that’s a good place to start as well as looking at the code.

Previously, a particle interval would do little more than start a particle system, wait for a specified amount of time, then remove the effect from the scenegraph and clean the system up.

Now, it’s a bit more in line with how other intervals work, with things like being able to speed up, slow down and even pause an effect (for an easy Matrix-style bullet-time effect). One thing to remember though is that the particle intervals must always travel forward in time. Particle systems are fairly non-deterministic since they’re strength is in their randomness. The interval has no way of moving back to a previous state and can only move the system forward.

Otherwise, things that may cause a bit of confusion are the ‘cleanup’ and ‘softStopT’ parameters.

cleanup should be set to True if the effect is a “one-off” effect where you just want to set it up and forget about it. If you do this, and the interval needs to be stopped early, then you should use “finish()” rather than “pause()” to ensure that the effect is indeed cleaned up. If you want to keep an effect around, but perhaps use several intervals on it over time, set cleanup to False.

softStopT makes use of the new softStop() on ParticleSystems. It sets the birth rate of the system to a very large number, which stops any new particles from being generated, but allows the existing particles to continue on their normal course. This was done to make it easier to have a particle system fade out rather than just disappear. A good starting value for this parameter is the max particle lifespan.

Hope this helps!


No really, lol. I achieved the effect you’re trying to achieve by accident. It was pretty annoying as I didn’t want the particles to stop but to disappear.

Anyway I think I just killed the interval that was responsible for the particle effect and they stopped. Try it out, I know there is a way to make that happen :wink: